Mac Safari not maintaining position in list


(Sam Saffron) #1
  1. Navigate down the topic list
  2. Click topic
  3. Click back

expected

I am in the same position in topic list

actual

I am in position 0 of the topic list

cc @eviltrout

(also visual looks pretty horrible with swipe back cause you get a double render)


(Luke S) #2

Not just safari. Be been browsing on chrome mobile (android) tonight, and the exact same thing is happening to me. I don’t normally notice it because I just use my mobile to check on new topics and read any replies to threads I am tracking. (Stuff tends to disappear as you work your way through those, so you are always at the top of the list anyway)


(Robin Ward) #3

I can’t reproduce this unless I don’t scroll down enough. But that’s always been the behavior and not just in Safari – do you see the URL change to /latest/more?


(Luke S) #4

I just checked and you are right. This only happens if the topic is in the first batch loaded. (i.e. : not /more) A little jarring, given the way that infinite scroll works otherwise. Also more noticeable on mobile devices, because the default content load takes up more screens - you can scroll three or four pages worth of content before you need to load more.


(Jeff Atwood) #5

Yeah this is the way it has always been @sam since launch, slight misunderstanding here.

Probably we should improve it either way @eviltrout.


(Jeff Atwood) #6

Didn’t you fix this at some point @eviltrout?


(Sam Saffron) #7

Actually this is now 100% re-opened on all browsers which @eviltrout will be fixing.


(Jeff Atwood) #8

Now is it fixed?

Will there have to be beatings? :facepunch::boom:


(Sam Saffron) #9

It looks ok to me now …


(Jeff Atwood) #10