MaxMind not showing isp or location after adding license key

Earlier this morning I saw the news about MaxMind requiring a license key, and I signed up, generated a key, and rebuilt the app after placing the key in app.yml. However, after rebuilding, I can no longer see ISPs or locations.

image

I did not notice any errors during rebuilding, and when i ran rake maxminddb:get it was indicated that the files were downloaded successfully.

root@discourse-app:/var/www/discourse# rake maxminddb:get
Downloading MaxMindDb's GeoLite2-City...
Downloading MaxMindDb's GeoLite2-ASN...

The only clue I found (which might indicate that it’s a MaxMind issue) is two lines in my production log.

IP [Hidden] could not be looked up in MaxMind GeoLite2-City database. : end of file reached
IP [Hidden] could not be looked up in MaxMind GeoLite2-ASN database. : end of file reached

However I am now scratching my head on this since every single IP address I attempt to look up returns this error.

Note: I also tried DISCOURSE_REFRESH_MAXMIND_DB_DURING_PRECOMPILE_DAYS=7 which didn’t seem to fix anything, and leaving out the variable did nothing.

5 Likes

We need this to work and will check into it on Monday cc @sam

2 Likes

This should be fixed per:

Previously we downloaded a .gz file, the new file we get is .tar.gz so we need to hunt for the actual DB file once extracted

7 Likes