Meta.d logo cut off on right edge in Firefox 30


(Bill Ayakatubby) #1

You can see in the image that the right edge of the “e” is cut off. Firefox 30, Win 7 Pro SP1 x64.


Missing e in the logo
The right edge of the logo in the banner is clipped in Firefox
(Jeff Atwood) #2

I believe this has been opened before. It’s a true bug in Firefox, not us.


(Jens Maier) #3

Seems to be related to client-side zooming in Firefox: when zoomed in, the image grows proportionally more then the box it is shown in. That’s indeed a bug in Firefox.

Reset the zoom level to 100% by pressing Ctrl+0 (zero) and see if that changes anything.


(Bill Ayakatubby) #4

Good thought, but it’s not a zoom issue.


(Jens Maier) #5

Are you on a device with a high pixel density display or 4K monitor? If you’re on Windows, what’s your system DPI setting?

If this setting is set to anything other then “smallest” (or “smaller”? I only have localized Windows versions available to me, unfortunately), it may cause implicit zooming in Firefox.


(Bill Ayakatubby) #6

This computer’s screen settings haven’t changed since I set them up nearly three years ago. The logo looked fine until a couple of weeks ago.


(Jens Maier) #7

Well, in that case…


(Johan Jatko) #8

Its a firefox bug, but seems to be solvable by explicitly specifying width/height for the image. (and not letting it use auto and max-height etc)

Sorry for bump but its a fix if people are annoyed by it. =)


(Daniel Gagnon) #9

It’s fine in Firefox 31 and Firefox users tend to be on relatively recent versions of their browser.


(Mittineague) #10

How much of a problem is this really?

OK, for us nit-picky devs it’s a thorn, but for the average user? I doubt most would notice unless they were specifically looking for it.


(PJH) #11

Where is the barrier where one should stop caring about problems? Regarding issues like this, 1px? 10px? 100px? Half the screen?


(TechnoBear) #12

I’m seeing it in Firefox 31 - although I’d never have noticed if it hadn’t been for this thread.


(Sam Saffron) #13

I think you are misunderstimating the power of OCD, if I were to be using firefox full time this would drive me nuts


(Daniel Gagnon) #14

When Mozilla fixed it already.


(Sam Saffron) #15

For the record I am using Firefox 31.0 here and not seeing the issue, if I had a repro I would sort it out.


(PJH) #16

You’re missing my point entirely. If there’s another similar issue in future for example, should it be ignored if it’s only 1px? 10px? etc.


(TechnoBear) #17

Firefox 31 on Ubuntu Linux - screen width 1240px, if that makes any difference?

Web Dev toolbar shows the image is scaled to 148px by 40px. Adding the width to the max-height on the stylesheet fixes the issue, as mentioned above:

``.d-header #site-logo {max-height: 40px;    width: 148px;}


(Sam Saffron) #18

Yeah only some widths are affected. It appears the resizing algorithm if Firefox is buggy … hmmm.


(Jeff Atwood) #19

Yet another reason, as if we needed one, not to use Firefox!

Hopefully they will fix this bug soon. Can someone open it on their bug tracker if it isn’t already?


(Sam Saffron) #20

OK I fixed this here, it is partly our fault

@awesomerobot our logo is an odd size, 66px height, that is just wrong, we should have a 80px hight logo so it works perfectly with retina (which usually has pixel ratio of 2).

I chucked in a site customisation that makes height and width explicit, we should disable that when we upload a logo that is 80px high.

Leaving this fixed bug open till Kris uploads a 80px high logo :slight_smile: