Migrating an old Discourse install to Docker


(ben_a_adams) #24

ish [quote]EXCEPTION: You’re trying to import a more recent version of the schema. You should migrate first![/quote]
Guess I’ll have to look at the upgrade your upgrade info :smiley:


And done! Wow much improved - so many changes hiding behind my unsynced git commit XD


#25

I am trying to migrate non-Docker install to Docker install (both latest version) but i get this error when trying to do the Backup from discourse admin:

[2015-04-21 21:08:25] pg_dump: server version: 9.3.6; pg_dump version: 8.4.20
[2015-04-21 21:08:25] EXCEPTION: pg_dump failed

Any ideas?

EDIT: Resolved by doing a symlink like this:

ln -s /usr/pgsql-9.3/bin/pg_dump /usr/bin/pg_dump --force

(Kane York) split this topic #26

2 posts were split to a new topic: How do I connect directly to the database to load in data?