# 마이그레이션 실패: 관계 "user\_required\_fields\_versions"가 이미 존재합니다

**URL:** https://meta.discourse.org/t/migration-failed-relation-user-required-fields-versions-already-exists/325378
**Category:** Self-hosting
**Tags:** unsupported-install
**Created:** [9월 6, 2024, 9:16오후 UTC](https://meta.discourse.org/t/migration-failed-relation-user-required-fields-versions-already-exists/325378 "2024-09-06T21:16:58Z")
**Posts on this page:** 1
**Showing post:** 19

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [9월 9, 2024, 6:47오후 UTC](https://meta.discourse.org/t/migration-failed-relation-user-required-fields-versions-already-exists/325378/19 "2024-09-09T18:47:55Z")

</div>

기존 postgres 폴더를 삭제하여 이 문제를 해결했습니다(실제로는 임시 저장소로 이동했으며 아직 삭제해야 합니다). 그런 다음 다시 빌드하고 최근 백업을 복원했습니다.

데이터베이스를 삭제한 후에도 AI 플러그인에서 여전히 오류가 발생하여, 플러그인을 제거한 후에 비어 있는 사이트를 다시 빌드하고 백업을 복원할 수 있었습니다. 확실히 하기 위해 그 후에도 다시 빌드했습니다.

제 가설은 데이터베이스와 마이그레이션 기록이 어긋나게 된 것이 어떤 방식으로든 원인이 되었다는 것입니다.

이 사이트는 6월경에 CDCK에서 마이그레이션되었습니다.

---

_[View the full topic](https://meta.discourse.org/t/migration-failed-relation-user-required-fields-versions-already-exists/325378)._
