Minimum Development Machine Requirement


(Khoa Nguyen) #1

I’m trying to set up a Discourse Development Environment on my laptop.

  • Windows 8.1 64 bits
  • Core i5 2.6 GHz
  • ram 4gb
  • 2 HDD (one for OS and one for Virtual Box image + Discourse source)

I’m familiar in develop with Vagrant. The installation progress went smoothly.
Try to request Discourse at localhost:4000
The console tell this information:

But the browser’s tab seem to load forever with Vagrant Discourse in the title.
Is this because my laptop ? I tried to increase VM machine RAM into ~2GB but still not work


Failed to launch discourse
(Jeff Atwood) #2

This is due to an issue with Rails using thousands of files and absurdly slow filesystem access in Vagrant on windows. If you can develop in a Linux VM you will see much better performance.


Failed to launch discourse
(Khoa Nguyen) #3

All right, I’ll give it a tried. Downloading ubuntu…
But maybe I don’t need a full Environment. I’m trying to write a import script for my current discussion app. Command line a good enough


(cpradio) #4

Yes, that is what I did. And then I shared Guest Port 3000 to Host Port 3000 (look in the Networking section of your VM), so I could pull up the Discourse site on my main machine.

The actual VM runs the Server version of Ubuntu, so I don’t have to spend any resources of the VM on Ubuntu’s Window Manager.


(Khoa Nguyen) #5

What purpose when you shared guest port 3000 to host port 3000? Both 3000 and 4000 port on host machine are free


(cpradio) #6

So I could use my primary machine to connect with the Discourse instance. Without sharing the port via the network, I couldn’t connect to it (same with SSH). Maybe due to the fact that I was using VirtualBox and it sandboxes VMs or the network configuration I used, but it is something you’ll want to be mind of.


(Khoa Nguyen) #7

My installation works out of box. No configuration required. I can connect to it using a normal ssh programe like PuTTy


(cpradio) #8

What VM software are you using (as now I’m curious), here is what my VirtualBox Network settings look like


(Khoa Nguyen) #9



(cpradio) #10

Ah, so you do have port forwarding rules :smile: I didn’t use the vagrant file, so I had to manually set mine up. As I made a different development environment.


(Ionuț Staicu) #11

I tried couple of days ago to install into a vbox machine (following this guide) and yet the loading took forever (i ditched after a minute or so of loading).

I guess the best approach would be to either have another PC for development, or just use a VPS for development.


(Sam Saffron) #12

A VM works fine, in fact I do all my development on a Linux VM running in Windows 8.1.