Missing czech translations


(Jakub Vančišin) #1

Hi, it looks like there are some missing translations for the Czech language version:

[cs.created_lowercase]
[cs.last_post_lowercase]
[cs.posts_lowercase]
[cs.views_lowercase]
[cs.users_lowercase]
[cs.notifications.*]
[cs.search.context.topic]
[cs.user.log_out]

These are just examples, there is more of them. I’ve joined the czech translation team on Transifex to translate them, but I wasn’t able to find them. So I was wondering, are those keys missing in the czech resource files? Or where can I find them so I can translate them?


(Jeff Atwood) #2

Any word on this @techapj?


(Arpit Jalan) #3

Hi @vancisin.

Is your Discourse instance updated to latest beta version? The created_lowercase string is present in Czech locale file:

The trick is to search for locale string not the variable, so when you will search for created on Transifex, you will see:


(Jakub Vančišin) #4

Thanks for the advice, update worked and most of them is now correctly translated. However there are still few remaining:

[cs.user.dismiss_notifications]
[cs.user.dismiss_notifications_tooltip]
[cs.admin.impersonate.help]
[cs.admin.user.like_count]
[cs.admin.user.cant_delete_all_too_many_posts]
[cs.admin.user.warnings_received_count]
[cs.admin.user.flags_given_received_count]
[cs.admin.user.sso.title]
[cs.admin.user.sso.external_id]
[cs.topic.notifications.reasons.1]
[cs.badges.allow_title]
[cs.badges.multiple_grant]
[cs.show_help]
[cs.admin.badges.icon]
[cs.admin.badges.icon_help]
[cs.admin.badges.image]
[cs.admin.badges.query]
[cs.admin.badges.preview.modal_title]
[cs.admin.badges.preview.grant_count]
[cs.admin.badges.preview.sample]
[cs.admin.badges.preview.grant.with_time]
[cs.admin.badges.auto_revoke]
[cs.admin.badges.target_posts]
[cs.admin.badges.trigger]
[cs.admin.badges.allow_title]
[cs.admin.badges.listable]
[cs.admin.badges.show_posts]
(and probably some more)

I’ve tried to find them both on transifex and in config/locales/server.cs.yml and config/locales/client.cs.yml, but with no luck. Are those missing or should I look somewhere else?


(Marcin Rataj) #5

Protip: try searching using KEY: filter (using values without cs. prefix):