Missing "expansion ellipsis" / extra drawer on posts


(Zane Beckman) #1

Continuing the discussion from Move some post actions to “extra drawer”:

Certain actions on posts are supposed to be accessible using an expansion ellipsis.

Here’s what my configuration has:

But the “expansion ellipsis” is nowhere to be found:


(cpradio) #2

Are you logged in as staff? Many of those actions require you to be logged in as staff.


(Zane Beckman) #3

I have “admins” and “staff” permission groups, and all trust levels, but not “moderator”.


(Zane Beckman) #4

I got it figured out. The “hidden” items must be present in the top box for the expansion ellipsis to be shown. (In other words, they must be duplicated.)

That got the ellipsis to show, but it’s still not quite in the right spot. I’m happy with the result, but maybe someone should look at it.


(cpradio) #5

Can you explain that further?


(Jens Maier) #6

The logic here is that if any buttons are hidden behind the ellipsis button, then the ellipsis is always inserted as the second to last button. Since the last visible button is, in your case, the share button, the ellipsis is inserted just before that.
If you switch Reply and share, Reply will always be the last button with the ellipsis appearing just to its left and after the share button.

TL;DR, Reply should be the last entry in the post menu list. :wink:


(Kane York) #7

Maybe this should be changed so that the expansion ellipsis gets a position in the menu, too? Maybe ‘…’ in the setting, then it goes in that spot.


(Zane Beckman) #8

This was exactly my thought. Either “…” or “more” or something along those lines.


(system) #9

(Sam Saffron) #10