# Mistakes when upgrading docker image to 1.3.3

**URL:** https://meta.discourse.org/t/mistakes-when-upgrading-docker-image-to-1-3-3/44913
**Category:** Support
**Created:** [May 27, 2016, 4:32pm UTC](https://meta.discourse.org/t/mistakes-when-upgrading-docker-image-to-1-3-3/44913 "2016-05-27T16:32:57Z")
**Posts on this page:** 13
**Page:** 1

<div class="post-metadata">

### Author: ![CT075](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/ct075/32/375367_2.png) [@CT075](https://meta.discourse.org/u/CT075)
#### Post date: [May 27, 2016, 4:32pm UTC](https://meta.discourse.org/t/mistakes-when-upgrading-docker-image-to-1-3-3/44913/1 "2016-05-27T16:32:57Z")

</div>

Hi -

We were attempting to upgrade our discourse installation via ssh (as the online upgrader seemed to not be working) using the following commands:

```
 cd /var/discourse
 git pull
 sudo ./launcher rebuild app

```

However, on rebuild, we get the following errors:

```
 Pups::ExecError: /root/upgrade_postgres failed with return #<Process::Status: pid 46 exit 1>
 Location of failure: /pups/lib/pups/exec_command.rb:108:in `spawn'
 exec failed with the params "/root/upgrade_postgres"
 9e8b63f0e289db391bb044443f449b122b5180399e2bd231bcfb10c4ce12a92c
 **FAILED TO BOOTSTRAP** please scroll up and look for earlier error messages, there may be more than one

```

There are no other errors that I can see, nor can I attempt to go back to the online site upgrader to retry (because the site is now dead due to the rebuild failing). We’d like to get our site back up ASAP.

Help?

---

<div class="post-metadata">

### Author: ![featheredtoast](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/featheredtoast/32/116994_2.png) [@featheredtoast](https://meta.discourse.org/u/featheredtoast)
#### Post date: [May 27, 2016, 4:38pm UTC](https://meta.discourse.org/t/mistakes-when-upgrading-docker-image-to-1-3-3/44913/2 "2016-05-27T16:38:07Z")

</div>

I haven’t updated my instance yet, but I know that there were a lot of infra updates with the latest image release – take a peek into this topic here, this should outline a few extra steps to get things back up:

[https://meta.discourse.org/t/discourse-docker-image-version-1-3-3-released/44778](https://meta.discourse.org/t/discourse-docker-image-version-1-3-3-released/44778)

---

<div class="post-metadata">

### Author: ![CT075](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/ct075/32/375367_2.png) [@CT075](https://meta.discourse.org/u/CT075)
#### Post date: [May 27, 2016, 7:15pm UTC](https://meta.discourse.org/t/mistakes-when-upgrading-docker-image-to-1-3-3/44913/3 "2016-05-27T19:15:43Z")

</div>

Thanks, that was helpful!

Unfortunately, I think I managed to screw it all up by doing the pg upgrade stuff in the wrong order (specifically, I forgot to backup the database before rebuilding the app again). I do have the files saved as postgres\_data\_old, but I can’t seem to get at them (my pg9.3 also seems to have disappeared in favor of pg-xc). Am I screwed? Currently all I’m seeing is the default discourse install

---

<div class="post-metadata">

### Author: ![Chopper](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/chopper/32/57073_2.png) [@Chopper](https://meta.discourse.org/u/Chopper)
#### Post date: [May 27, 2016, 7:39pm UTC](https://meta.discourse.org/t/mistakes-when-upgrading-docker-image-to-1-3-3/44913/4 "2016-05-27T19:39:43Z")

</div>

what about automatic backup ? you havn’t one ?

---

<div class="post-metadata">

### Author: ![CT075](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/ct075/32/375367_2.png) [@CT075](https://meta.discourse.org/u/CT075)
#### Post date: [May 27, 2016, 7:43pm UTC](https://meta.discourse.org/t/mistakes-when-upgrading-docker-image-to-1-3-3/44913/6 "2016-05-27T19:43:13Z")

</div>

We have an automatic backup (through discourse), though not of the entire server image. Is there a tutorial anywhere on how to restore backups via ssh? The only thread I found was [this one](https://meta.discourse.org/t/advanced-manual-method-of-manually-creating-and-restoring-discourse-backups/18273), but it doesn’t seem to apply to me (the files shown are .gz files, but the files I see in the backups folder are .tar)

---

<div class="post-metadata">

### Author: ![Chopper](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/chopper/32/57073_2.png) [@Chopper](https://meta.discourse.org/u/Chopper)
#### Post date: [May 27, 2016, 7:43pm UTC](https://meta.discourse.org/t/mistakes-when-upgrading-docker-image-to-1-3-3/44913/7 "2016-05-27T19:43:36Z")

</div>

At least, if you have backup you can setup a fresh install of Discourse and then restore the backup from the admin panel. At least…

---

<div class="post-metadata">

### Author: ![CT075](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/ct075/32/375367_2.png) [@CT075](https://meta.discourse.org/u/CT075)
#### Post date: [May 27, 2016, 7:52pm UTC](https://meta.discourse.org/t/mistakes-when-upgrading-docker-image-to-1-3-3/44913/8 "2016-05-27T19:52:27Z")

</div>

How would I do that? Would I just do a fresh install and copy the file (and/or my app.yml) into the relevant directory (and then the backup should just work itself)?

---

<div class="post-metadata">

### Author: ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)
#### Post date: [May 27, 2016, 7:56pm UTC](https://meta.discourse.org/t/mistakes-when-upgrading-docker-image-to-1-3-3/44913/9 "2016-05-27T19:56:57Z")

</div>

Go to Admin \> Backups in your web browser. Click “upload” in your web browser and upload the backup there.

---

<div class="post-metadata">

### Author: ![Chopper](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/chopper/32/57073_2.png) [@Chopper](https://meta.discourse.org/u/Chopper)
#### Post date: [May 27, 2016, 7:57pm UTC](https://meta.discourse.org/t/mistakes-when-upgrading-docker-image-to-1-3-3/44913/10 "2016-05-27T19:57:59Z")

</div>

For now, i will just wait more answer, maybe you can restore everthing so wait.

About the backup, you have this on the panel admin, (upload and restore option)

 ![](https://global.discourse-cdn.com/meta/original/3X/1/a/1a129273db3b3892b2d1c9d7e6338b5ddbe9ddd4.png)

I guess if you have a backup (and you can’t access to your current admin panel) you can setup fresh install then upload and restore the backup. 😏

**Edit**

don’t forget to allow backup on `/admin/site_settings/category/backups` thx to @cpradio

---

<div class="post-metadata">

### Author: ![CT075](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/ct075/32/375367_2.png) [@CT075](https://meta.discourse.org/u/CT075)
#### Post date: [May 27, 2016, 7:58pm UTC](https://meta.discourse.org/t/mistakes-when-upgrading-docker-image-to-1-3-3/44913/11 "2016-05-27T19:58:34Z")

</div>

Thanks. I assume that this means I’m screwed any other way…

---

<div class="post-metadata">

### Author: ![cpradio](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cpradio/32/4970_2.png) [@cpradio](https://meta.discourse.org/u/cpradio)
#### Post date: [May 27, 2016, 8:13pm UTC](https://meta.discourse.org/t/mistakes-when-upgrading-docker-image-to-1-3-3/44913/12 "2016-05-27T20:13:37Z")

</div>

No, you need to enable the `allow restore` site setting to allow that restore button to be used.

---

<div class="post-metadata">

### Author: ![CT075](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/ct075/32/375367_2.png) [@CT075](https://meta.discourse.org/u/CT075)
#### Post date: [May 27, 2016, 9:21pm UTC](https://meta.discourse.org/t/mistakes-when-upgrading-docker-image-to-1-3-3/44913/13 "2016-05-27T21:21:22Z")

</div>

Thanks for the help, everyone! We’re back online (with 10 days of data lost), thanks to everyone.

---

<div class="post-metadata">

### Author: ![JammyDodger](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/jammydodger/32/254611_2.png) [@JammyDodger](https://meta.discourse.org/u/JammyDodger)
#### Post date: [June 8, 2024, 12:45pm UTC](https://meta.discourse.org/t/mistakes-when-upgrading-docker-image-to-1-3-3/44913/14 "2024-06-08T12:45:34Z")

</div>

This topic was automatically closed after 2933 days. New replies are no longer allowed.
