Mixed content warning on one script only stops Preview working


(WorldOfMadness) #1

I get this error below with one scrip that runs the Preview,

I tried the force https but the site breaks the login when i try that and the site works fine htts wise except this one thing Any Ideas site works fine otherwise than that.

Debian 8 - Plesk Onyx

Mixed Content: The page at 'https://community.worldofmadnesstv.uk/t/about-the-infomation-category/12' was loaded over HTTPS, but requested an insecure script 'http://community.worldofmadnesstv.uk/assets/markdown-it-bundle-278dd87cca85c40ed9c85bff51af14639959f40df44b285fe0007619fc1be8e9.js'. This request has been blocked; the content must be served over HTTPS.

(Bhanu Sharma) #2

Why is that?
are you using cloudflare as well?

Are you using some kind of SSO that needs You to be on http instead?

if it is discourse or any other supported login then they all require You to be fully https …


(Michael Friedrich) #3

Can you share how you’ve exactly forced https?

Also, try to access the site via http only - not only on your browser, but also with shell clients.

It seems that your site enforces users to login, without showing the home page. This redirect uses http instead of https.

Please share the configuration of that too.

root@monitoring-portal-app:/var/www/discourse# irb

irb(main):002:0> require 'open-uri'; open 'https://community.worldofmadnesstv.uk'
RuntimeError: redirection forbidden: https://community.worldofmadnesstv.uk/ -> http://community.worldofmadnesstv.uk/login
	from /usr/local/lib/ruby/2.4.0/open-uri.rb:225:in `open_loop'
	from /usr/local/lib/ruby/2.4.0/open-uri.rb:151:in `open_uri'
	from /usr/local/lib/ruby/2.4.0/open-uri.rb:721:in `open'
	from /usr/local/lib/ruby/2.4.0/open-uri.rb:35:in `open'
	from (irb):2
	from /usr/local/bin/irb:11:in `<main>'

Cheers,
Michael


(Jeff Atwood) #4

If you cannot force https your install is misconfigured.


(WorldOfMadness) #5

No cloudflare and no sso currently. i have quite a few websites that all run fine on https:// but discourse seems to be a bit of a complicated one


(WorldOfMadness) #6

I hve turned off the locked site im building currently on that server so you can see the options and signup pages etc


(Joshua Rosenfeld) #7

You need to force HTTPS in Discourse site settings as well.


(Bhanu Sharma) #8

My Discourse installations, Discourse meta and hundreds of other discourse installs online have came with SSL installed out of the box courtesy of letsencrypt.

I Guess there is some configuration issue at Your installation that is restricting it’s ssl capabilities.

I Guess You should start with a bit of Googling of enable SSL on Discourse.


(Michael Friedrich) #9

Does your problem still occur after removing the custom redirect?

Cheers,
Michael


(Mindaugas Bartusevičius) #10

Yap the problem is up its then installing the discourse on plesk then its a bit problem i gess the ssl mis configuraton …

1 of all if instaling discourse on plesk with the ssl of setup then geting error to meny redirections , but then instaling without ssl on setup then instaling but mix http with https …