Modification for "Let's get this discussion started" top banner


(Frans Thamura) #1

I have "Let’s get this discussion started! There are currently 0 / 5 topics and 0 / 30 posts. New visitors need some conversations to read and respond to. "

how to change it?


(cpradio) #2

You can hide that message using the following setting show create topics notice

You can customize the text by going to Admin > Customize > Text Content and searching for js.too_few


(Jeff Atwood) #3

You understand this message is only visible to staff, yes?


(Mike Taber) #4

I understand that now that you’ve said it but that’s not clear in the UI at all.

Separately, we did an import of some 22k+ forum posts. The message still shows up. I suspect the totals are cached somewhere and may not ever be recalculated because this message was still in our instance. I’ve no idea how to force it to refresh/recalculate those numbers.


(Jeff Atwood) #5

Sure, any advice here @neil?


(Neil Lalonde) #6

What does your /about page show? It’s counting public posts, so are all your topics/categories private? If so, then you should disable the show create topics notice setting.


(Mike Taber) #7

The /about page shows the right totals.
3k All time topics
21.3k Posts

I disabled the message using the show create topics notice setting because it was annoying and even with 8 Topics and 93 posts it didn’t seem to be going away.

You mentioned that it’s counting public posts too… I’m not sure that it is. All of our categories are marked private and even with 8 new topics & 93 posts since yesterday when the site went live, it was still showing zeros. Bug maybe?

FYI: SUPER LOW priority for me. I disabled the message because it didn’t matter to me and wasn’t correct because we imported data. But I wanted to let you know what I was seeing.