# Sposta un sito Discourse su un altro VPS con rsync

**URL:** https://meta.discourse.org/t/move-a-discourse-site-to-another-vps-with-rsync/43812
**Category:** Sysadmins
**Tags:** migrations, how-to
**Created:** [6 Maggio 2016, 8:21pm UTC](https://meta.discourse.org/t/move-a-discourse-site-to-another-vps-with-rsync/43812 "2016-05-06T20:21:38Z")
**Posts on this page:** 1
**Showing post:** 21

<div class="post-metadata">

### Author: ![piratdavid](https://avatars.discourse-cdn.com/v4/letter/p/ba9def/32.png) [@piratdavid](https://meta.discourse.org/u/piratdavid)
#### Post date: [13 Dicembre 2022, 2:54pm UTC](https://meta.discourse.org/t/move-a-discourse-site-to-another-vps-with-rsync/43812/21 "2022-12-13T14:54:29Z")

</div>

Ciao!

Sto cercando di seguire i passaggi di @scottfsmith. Riesco a completare rsync. Non mi interessa ottenere le modifiche più recenti tramite rsync poiché sto solo testando una nuova versione di Linux con il mio sito esistente per vedere se tutti i miei plugin funzionano. Quindi non eseguo la seconda esecuzione di rsync. Tentare di eseguire `./launcher rebuild app` produce errori.

```plaintext
2022-12-13 14:43:01.974 UTC [59] LOG: il sistema del database è stato interrotto; ultimo avvio noto alle 2022-12-13 10:23:29 UTC
2022-12-13 14:43:02.075 UTC [59] LOG: record di checkpoint primario non valido
2022-12-13 14:43:02.075 UTC [59] PANIC: impossibile individuare un record di checkpoint valido
2022-12-13 14:43:03.137 UTC [56] LOG: processo di avvio (PID 59) è stato terminato dal segnale 6: Abortito
2022-12-13 14:43:03.137 UTC [56] LOG: avvio interrotto a causa di errore del processo di avvio
2022-12-13 14:43:03.231 UTC [56] LOG: il sistema del database è spento
I, [2022-12-13T14:43:06.699692 #1] INFO -- : 
I, [2022-12-13T14:43:06.711862 #1] INFO -- : > su postgres -c 'createdb discourse' || true
createdb: errore: impossibile connettersi al database template1: impossibile connettersi al server: Nessun file o directory
	Il server è in esecuzione localmente e accetta
	connessioni sul socket di dominio Unix "/var/run/postgresql/.s.PGSQL.5432"?
I, [2022-12-13T14:43:06.917008 #1] INFO -- : 
I, [2022-12-13T14:43:06.917421 #1] INFO -- : > su postgres -c 'psql discourse -c "create user discourse;"' || true
psql: errore: impossibile connettersi al server: Nessun file o directory
	Il server è in esecuzione localmente e accetta
	connessioni sul socket di dominio Unix "/var/run/postgresql/.s.PGSQL.5432"?
I, [2022-12-13T14:43:07.007654 #1] INFO -- : 
I, [2022-12-13T14:43:07.008155 #1] INFO -- : > su postgres -c 'psql discourse -c "grant all privileges on database discourse to discourse;"' || true
psql: errore: impossibile connettersi al server: Nessun file o directory
	Il server è in esecuzione localmente e accetta
	connessioni sul socket di dominio Unix "/var/run/postgresql/.s.PGSQL.5432"?
I, [2022-12-13T14:43:07.087098 #1] INFO -- : 
I, [2022-12-13T14:43:07.087319 #1] INFO -- : > su postgres -c 'psql discourse -c "alter schema public owner to discourse;"'
psql: errore: impossibile connettersi al server: Nessun file o directory
	Il server è in esecuzione localmente e accetta
	connessioni sul socket di dominio Unix "/var/run/postgresql/.s.PGSQL.5432"?
I, [2022-12-13T14:43:07.167221 #1] INFO -- : 
I, [2022-12-13T14:43:07.168041 #1] INFO -- : Terminazione processi asincroni

```

Non riesco a capire abbastanza da trovare una soluzione. Alcune ricerche suggeriscono che il container debba essere fermato ma non è avviato. Qualche idea?

Grazie  
David

---

_[View the full topic](https://meta.discourse.org/t/move-a-discourse-site-to-another-vps-with-rsync/43812)._
