My app.yml is missing...?


(Christian) #1

I tried to rebuild my app after loading a backup, because I had some weird artifacts on the site. But the server responds with:

Config file was not found, ensure containers/app.yml exists

ls: cannot access '*.yml': No such file or directory
Available configs ( )

What happened? And how can I fix this?


(Jay Pfaffman) #2

Could it be that said backup doesn’t include app.yml?


(Christian) #3

It could be, it shouldn’t though. I’ve used the same backup before and had no problems.
And it still leaves me without an app.yml


(Rafael dos Santos Silva) #4

Backups doesn’t contain the app.yml.


(Jay Pfaffman) #5

I thought that “backups” referred to some OS-level backups, not a Discourse backup/restore.

@TheDrDentz, this defies explanation. Do you mean a Discourse backup that you restored from the web interface?


(Christian) #6

Yes, I do! I made a backup a while ago, downloaded it, and now restored the forum from that backup.


(Jay Pfaffman) #7

Then there is no obvious explanation. It’s something preposterous like you’re logging in to the wrong server, you’re in the wrong directory, or, and this one might be the most promising, perhaps you did a ./launcher enter app and then tried to rebuild from within the container?


(Christian) #8

I’m not the only one working on this server and the other admins have tied their luck on the problem aswell. And it looks like the discourse install is there, only the app.yml is missing. we can still reach the website, but the forum is locked in readonly mode.
Would it be possible to copy the .yml from another discourse and then edit it so it fits mine?


(Jay Pfaffman) #9

There is a sample in samples/standalone.yml or you could run ./discourse-setup.


(Christian) #10

running the setuo didn’t work earlier. But i can’t connect to the server right now, to copy the exact error output. But I’ll share the info about the sample and we’ll try to work it out from there. Thanks for now, I’ll be posting if we figure something out.


(Andrew Waugh) #11

Is this a standard docker install?

If it is, then you must have had a something.yml in /containers to get through the restore.

Could it be that someone has renamed app.yml (restore.yml, old_app.yml or app.oldyml come to mind)?

Running ./discourse-setup should create a new app.yml for you, but check what is in /containers first.


(Tobias Eigen) #12

What you want to do, methinks, is install a new discourse from scratch, copy your backup file into the backups folder, then restore the backup via the web interface. It will then bring back your site.

You will need to set up your app.yml again to match what you had previously. In the future, whenever you make a change to your app.yml file you want to copy it to your local so you can easily recreate it again next time.

You do do not want to mess with the tar.gz backup file yourself. Let the discourse backup/restore do the heavy lifting. :wink:

(I just did a quick search for a restore from backup #howto topic but didn’t find one - maybe someone else can direct you to the right place to inform yourself further on how the backup/restore process works…)