My forum is opened with another link


(TheBurningMan) #1

my forum link is - http://forum.buzzbasement.com
But when i searched google with my company name “BuzzBasement” , I found that another URL is targeted to my forum and in top 10 results.
URL - http://www.takiya-inject.asia/categories

Is it a problem to think.
Kindly suggest me


How to deny request from unauthorized domain?
(TheBurningMan) #2

I typed URL in place of this but it automatically converted into name


(TheBurningMan) #3

When I google “BuzzBasement Community”, this link is on no. 1 :rage::rage::rage:. This is too much


What should Invite right now


(Vinoth Kannan) #4

It can be related to below topic.

Are you from digitalocean?


(Felix Freiberger) #5

Set up HTTPS:

This not only makes your site more secure, but has the added side effect of breaking the incorrect domain :wink:


(TheBurningMan) #6

Yup, I am on digital ocean


(TheBurningMan) #7

Now, will do that definitely


(Vinoth Kannan) #8

The other issue I linked also hosted on digitalocean. May be they having some routing issue. If you can’t find the solution try their support team also.


(TheBurningMan) #9

Thanks, I am mailing them right now.


(Felix Freiberger) #10

No need to do that, DigitalOcean is fine. Both domains simply resolve to the same IP, and you need to get your server to stop responding to the wrong domain name :slight_smile:


(TheBurningMan) #11

How can I do that. I never faced this type of issue before. Can you provide a demo


(Felix Freiberger) #12

I linked you to the instructions above – simply follow this howto and you should be good to go :slight_smile:


#13

I have come across this situation with one my clients’ sites.

It looks like the other site was once using the same droplet ip address like yours.
You will have to contact DigitalOcean and then ask them to remove the other site from their DNS - so that it will no more be linked to your ip address (because it now belongs to you)


(TheBurningMan) #14

Same :grin:, I was going through this. Thanks


(Dean Taylor) #15

I kind of think why we are seeing this happen more frequently is because the canonical meta tag is missing from the homepage:
e.g. <link rel="canonical" href="http://www.example.com/" />

canonical meta tag exists on other pages such as categories and topics, but not on the home page.

I believe this topic has requested it before:

I believe adding this will prevent this from happening again (at least with Google).


(TheBurningMan) #16

I contacted Digital Ocean but they said “there is no way to prevent a person from pointing their domain at an IP address”


#17

Like they said, best way to tackle this would be by using virtual hosts file such that “only your domain name will be able to display the content of the website from your ip address” - you might need to take the help of a sys-admin for this though. Or if you’d like to do it yourself, you may ask check the serverfault.com site.


(Felix Freiberger) #18

Sorry to repeat myself, but… setting up HTTPS is the easiest way to do that, as it requires no external server software – everything will be handled by the built-in Nginx server and Let’s Encrypt client :slight_smile:

Did you try that already? If you got stuck, we’re here to help :slight_smile:


(TheBurningMan) #19

Now, I think this is the only option. I have very less knowledge of coding and your help really help in setting up this.
I just started setting this. Thanks


(TheBurningMan) #20

123
What I should do here @fefrei