My forum old images not see


(Hakan) #1

Images that have already been loaded do not appear.

https://oyuncum.com/t/msi-geforce-gtx-770-ekran-karti-incelemesi/2667

but i see transparent.png .

Most of the pictures I have uploaded in the past do not appear, what is the problem and how can I solve it?


(Jay Pfaffman) #2

Are your images stored locally or on S3?


(Hakan) #3

I use it with no standard settings. Actually I upload pictures to another server, but because I use topic list preview, I upload my own images to my server.

How fix my problem ?


(Jeff Atwood) #4

We do have a highly unfortunate current bug around this that @tgxworld is still fixing; try getting latest and rebuilding.


(Hakan) #5

I using latest versiyon, and now rebuild app trying.

İ wait.

Edit: I did launcher rebuild app but not see images.


(Sam Saffron) #6

Do a rebuild right now, images should be recovered in about 1 hour.


(Alan Tan) #7

Echoing what @sam said. We’ve added a onceoff job to fix the problematic posts so please rebuild.


(Dan) #8

Just this?

cd /var/discourse
./launcher rebuild app

(Dan) #9

I’m suffering this bug since 4 days ago: Topic List Previews
Only way I recover old images is to restore backup :-(.


(Hakan) #10

@tgxworld ı admin panel upgrade new discourse version update and launcher rebuild app.

But not change,

https://oyuncum.com/t/msi-z87-g45-gaming-anakart-incelemesi/2670

(Alan Tan) #11

Can you confirm that the onceoff job has already run?

./launcher enter app
rails c
OnceoffLog.where(job_name: "RecoverPostUploads").count

(Hakan) #12

ı did your command. What do I have to do now?


(Jay Pfaffman) #13

That should have solved your problem. Did it not?


(Hakan) #14

no, problem still exists

https://oyuncum.com/t/msi-z87-g45-gaming-anakart-incelemesi/2670

and

https://oyuncum.com/t/top-10-haftanin-en-cok-indirilen-torrent-filmleri/932

and new error logs.

!


(Sam Saffron) #15

Do you have CloudFlare enabled?


(Hakan) #16

Yes, I’ve been using cloudflare-template settings since I started using discourse. Cloudflare enabled, I have been using it for about 3 months. I have now encountered this problem


(Alan Tan) #17

What does the following give you?

./launcher enter app
rails c
Post.where(topic_id: [2670, 932], post_number: 1).pluck(:baked_at)

(Hakan) #18


(Alan Tan) #19

It looks like those posts were created in May and July respectively which was probably affected by a bug where a post may not be linked to the uploads if the background cooked post processor did not execute for whatever reason. We’ve improved the process such that it associates on save instead of inside a background job.

Since SiteSetting.purge_deleted_uploads_grace_period_days defaults to 30 days, we’re unable to recover the images as the images have most likely been deleted from the tombstone. The only way to restore the images is to re-upload the images.


(Hakan) #20

Pictures 30 days ago were not on a different server. I have already installed my own server. I have backups of my uploads folder, reinstalling the problem solved.