New bootstraps do not start because of thread_safe gem


(Kane York) #1

Because thread_safe (0.3.0) was yanked, this causes bundle install to fail and a newly bootstrapped Discourse will not start, leaving just the nginx 502 page.

I manually edited Gemfile.lock to set thread_safe to 0.2.0 and it works. But this is kind of an emergency situation - new installs are failing.


(Vikhyat Korrapati) #2

Pretty sure this was fixed earlier today, are you on latest?


(Kane York) #3

Whoops - @sam already got this:

https://github.com/discourse/discourse/commit/12513f430c5298a357ae31f799481f575a5c221b


(Jeff Atwood) #4