New category system bug with Chinese category name


(唐明星) #1

There are three bugs when using Chinese category name, you can try it by “新分类” if you can’t speak Chinese:

1)When created, the page comes to 404 category page

2)When switch by the new switch widget, no response(has just been fixed according the latest release I got)

3)After switch, can’t switch the tab( New, Unread, Read…)

Hope to fix it.


(Robin Ward) #2

What commit of Discoruse are you running? I fixed a bunch of non-english category name issues yesterday and all this was working.


(唐明星) #3

I checkout out the latest release, and the problem still exists.

My site is sjyyt.com, you can try there, too.

Thank you.


(Amit Friedmann) #4

Same with categories with hebrew characters. It started to happen since the upgrade to 0.9.7.2 worked fine with previous release.
The category links were assigned as /1-category, /2-category etc… Which is now lead to a blank page (404), and I don’t know what they were switched with, or totally deleted (even tough I can see them).
You can check here: http://ozim.co.il
Categories are only in hebrew.

Thx


(Sam Saffron) #5

@amitfrid that site is in desperate need for a hebrew locale, perhaps its worth contributing one?


(Amit Friedmann) #6

Yes,
I know that and I am willing to put the effort, I might even find one or two helpers. Definitely on my list.
Since I am putting a new forum right now I urgently need to fix the I18N problems first, that’s a new one and the other is reply-by-mail with hebrew characters.

Thx.


(Michael - DiscourseHosting.com) #7

It seems like all categories on @amitfrid’s forum have empty slugs (I checked the database).
The only category with a slug is ‘uncategorized’ and that’s the only link in the dropdown that is actually working.

db=# select id,slug from categories;
 id |     slug      
----+---------------
 12 | 
  7 | 
 11 | 
 13 | uncategorized
  4 | 
  3 | 
  1 | 
  9 | 
  6 | 
  5 | 
  8 | 
 10 | 
  2 | 
(13 rows)

(Sam Saffron) #8

@eviltrout can you have a look at this ?


(Robin Ward) #9

Sorry about that. There were a couple of parts I missed. If you get the latest version it should work properly now.


(Michael - DiscourseHosting.com) #10

As an exception, we have updated the software on the instance to master (instead of latest-release) so @amitfrid gets the fix immediately, given the severity of the bug in this particular case.

I can now confirm that the problem is solved !


(Amit Friedmann) #11

Thx @michaeld, @eviltrout I can confirm it’s fixed!
There is still one issue, tough, happened before the last fix:
I am getting an error on one specific category (the one in red that has 12 posts, link is /1-category) when trying to create a new topic: alert box with “Category is reserved”. I don’t see any setting difference between it an any other categories (except one category that has greater hotness value).It happens only on this category.


(Michael - DiscourseHosting.com) #12

At what moment are you getting that box? And is that really the exact message ? (since I cannot even find that string in the source code).


(Amit Friedmann) #13

I am getting it when clicking the “Create Topic” button with that category selected.
Here is a screenshot:


(Amit Friedmann) #14

I think that this specific category is really broken. In the categories page it says there are 12 topics were there only 4 actually. Other categories’s stat are correct.


(Michael - DiscourseHosting.com) #15

Weird, I cannot reproduce that on either Safari or Firefox.

If you go to Categories on your forum, the green one (top right) says 9, has 10. The orange one in top left says 2 has 3.
Also, the “view all 9…” button on the top right category is still broken.

(Oh, yes Sidekiq is running, no it doesn’t have failed jobs, yes I did re-trigger the update stats job.)


(Amit Friedmann) #16

What I’ve done was renaming the original category, create a new one with the right name and then move all the posts to it. On the new one I am able to create new topics, which solve that problem.
On the old one (the renamed) I still can’t, getting the same error. Also, now that the instance is on master, I don’t see the “Delete Category” button anymore on any of the categories, was that removed lately?


(Sam Saffron) #17

I am unable to reproduce the “is reserved” thing, but I did test the whole Chinese category creation thing locally and it seems to work fine.

If you can repro the “is reserved” thing on latest please open a new topic.


(Sam Saffron) #18