New Discourse Instance, Email not working


(Ek) #1

Hi all, Ive been having trouble getting my emails to work for about 2 days now. I first did the Digital Ocean one click install, test and signup emails weren’t delivered.

This morning I rebuilt my Digital ocean droplet using Ubuntu 18 and installed a new Discourse instance. Even with this new one, the emails just aren’t being delivered. The emails also don’t show up in my Mailgun logs. Ive spoken to both Mailgun and DO and they don’t know what the problem is.

I looked through my Discourse logs via terminal and found this error message (attached screenshot). Does anyone know what this is? Thanks


(Christoph) #2

Have you worked through these instructions?


(Ek) #3

Yup, twice. I’ve pretty much gone through that whole troubleshoot guide


(Jay Pfaffman) #4

Did you try port 2525?


(Ek) #5

Yup, tried each one at one point


(Bhanu Sharma) #6

Anything relevant in logs?
Are you sure DO is not blocking your email?


(Ek) #7

There was this error in my Discourse logs (attached) Not sure what it means though. No one has been able to tell me.


(Ek) #8

This morning when I checked my inbox, I saw 6 of the Discourse confirmation emails that hadn’t sent. Looks like they were delivered extremely late. I was able to sign in as admin but when I ran the test emails they failed. Im waiting on a response from my Mailgun support ticket.


(Bhanu Sharma) #9

This looks like something to do with your installation.

Connection to redis is failing!

Can you share details on what kind of install is it?


(Ek) #10

I actually used the discourse/INSTALL-cloud.md at master · discourse/discourse · GitHub tutorial the second time. The issue seems to be lessening, now I can see the failed emails in my Mailgun logs, before they didn’t even show up. Attached is the new error message in my Discourse logs. It looks like Redis isn’t outright failing but something is definitely still cracked. Thanks