"New Topic" composer triggers deletion nag after entering existing topic and exiting while composer minimized


(Kris) #1

Steps to reproduce

  1. Open the composer to create a new topic
  2. View an existing topic with the composer open (enter text into the textarea)
  3. Minimize composer
  4. Navigate back to topic list

When I navigate back to the topic list, the composer appears and the nag is triggered. Additionally, If I click “yes, abandon” at that point, nothing actually happens.

Expected behavior is that I can return to the topic list without being nagged about my new topic draft


No warning before destroying draft when composer is minimized
(Joshua Rosenfeld) #2

I’m not able to reproduce this. I followed your steps in Chrome on Windows, I did not receive the nag.


(Jeff Atwood) #3

Note that new topic drafts and reply drafts are very different animals. You can have an infinite number of new reply drafts (in theory, anyway, one per every topic), but only one (1) new topic draft at any given time.


(Jeff Atwood) #5

Note that this is how one triggers appearance of a New Topic draft. This, exactly, is the only way to do it.


(Joshua Rosenfeld) #6

Now I can repro - this is a strange bug.

If I open the new topic composer by typing c the nag does not appear. However, if I open the new topic composer by clicking :heavy_plus_sign: New Topic then the nag appears.

Can you confirm that the error does not occur when using the keyboard shortcut @awesomerobot?


(Kris) #7

Yep, seeing the same thing. Odd.


(Joshua Rosenfeld) #8

In this case the bug is old - I saw it months before Sam’s fix. Let’s move this to a new topic.

Please feel free to rename this @awesomerobot, couldn’t figure out how to explain succinctly in the title.