"New version available . ." message - now incorrect


(Philip Rhoades) #1

People,

I updated from an old DO server and custom installed Discourse version to the latest Docker version on another DO server but I am still getting these messages:

“A new version of Discourse is available.
Your version: 1.0.1
New version: 1.5.0
You may want to:
See what’s new in the GitHub changelog.
Upgrade by visiting http://lestp.org/admin/upgrade and pressing the “Upgrade” button.
Visit meta.discourse.org for news, discussion, and support for Discourse.”

How do I let the Discourse updating system know that that I am now using the latest version?

Thanks,

Phil.


(Felix Freiberger) #2

Try waiting 24 hours or visit /sidekiq/scheduler and click Trigger for Jobs::VersionCheck.


(Philip Rhoades) #3

This has been going on for weeks already.

Shows:

Jobs::VersionCheck about 3 hours ago OK 109 about 22 hours from now

  • so I don’t think the message is coming from the installation itself because it has the previous installation’s (a different DO server) old version number - it looks like it is coming from discourse.org which doesn’t know about the new installation?

Thanks,
Phil.


(Kane York) #4

When is the last time you rebuilt the container?

Also, what you should be seeing has a v on the front:


(Philip Rhoades) #5

I have never rebuilt it since installing it recently.

What I see is exactly what I posted first - copy and pasted from a plain text email (blank lines deleted and now the minor version has bumped):

A new version of Discourse is available.
Your version: 1.0.1
New version: 1.5.1
You may want to:
    See what's new in the GitHub changelog.
    Upgrade by visiting http://lestp.org/admin/upgrade and pressing the "Upgrade" button.
    Visit meta.discourse.org for news, discussion, and support for Discourse.

(Kane York) #6

http://forum.lestp.org/

Okay so #1 the forum has the incorrect URL set.

According to the HTML you’re running <meta name="generator" content="Discourse 1.5.0.beta13b - https://github.com/discourse/discourse version 37ccfbdb2a63a4ffe84dab056469f894d69b7b3a"> so that’s probably the problem here.


(Philip Rhoades) #7

Ah, yes, sorry . . the forum URL WAS originally just lestp.org but got changed . . but that doesn’t explain the version number problem?

I think that is correct but what does that mean? Why should I be getting emails that say the site is still on v1.0? Are you saying I should update to the latest version?

Thanks,
Phil.