# Ngnix fails to start on VM with IPv6 disabled

**URL:** <https://meta.discourse.org/t/ngnix-fails-to-start-on-vm-with-ipv6-disabled/112918>\
**Category:** Self-hosting\
**Tags:** unsupported-install\
**Created:** [March 29, 2019, 12:53pm UTC](https://meta.discourse.org/t/ngnix-fails-to-start-on-vm-with-ipv6-disabled/112918 "2019-03-29T12:53:59Z")\
**Posts on this page:** 1\
**Showing post:** 11

<div class="post-metadata">

**Author:** ![chrisc](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/chrisc/32/119982_2.png) [@chrisc](https://meta.discourse.org/u/chrisc)\
**Post date:** [March 29, 2019, 3:06pm UTC](https://meta.discourse.org/t/ngnix-fails-to-start-on-vm-with-ipv6-disabled/112918/11 "2019-03-29T15:06:33Z")

</div>

I agree that ideally the VM server and the DNS would be configured for IPv6, but this isn’t the case with this server and I might not be the only person still running a server using IPv4 so it appears fairly reasonable to me to disable IPv6 in the Nginx config in the Docker container, it is a simply one line solution in `containers/app.yml` and it does the job for now:

```yml
## Any custom commands to run after building
run:
  - exec: echo "Beginning of custom commands"
  - exec: sed -e 's/listen \[::\]:80;/#listen [::]:80;/' -i /etc/nginx/letsencrypt.conf

```

As far as I’m concerned this _“solution”_ is good enough for now…

---

_[View the full topic](https://meta.discourse.org/t/ngnix-fails-to-start-on-vm-with-ipv6-disabled/112918)._
