No address associated with hostname


#1
Jobs::HandledExceptionWrapper: Wrapped SocketError: getaddrinfo: No address associated with hostname

Sidekiq tells me there are a lot of problems with sending email currently. See below:

Mailgun told me that mail hasn’t been sent in a few days, but now (I just upgraded), it seems to be working fine:

I just upgraded Discourse like an hour ago, so it might be that the restart enabled the sending in and out again. Still, Sidekiq reports a lot of problems.

How to proceed?


(Jeff Atwood) #2

Looks like you have a DNS problem on your server maybe? I suggest rebuilding from command line

Please SSH into your server and run:

cd /var/discourse
git pull
./launcher rebuild app

#3

Thanks, doing that right now.

Edit: git pull:

remote: Counting objects: 182, done.
remote: Compressing objects: 100% (26/26), done.
remote: Total 182 (delta 103), reused 96 (delta 96), pack-reused 57
Receiving objects: 100% (182/182), 45.50 KiB | 0 bytes/s, done.
Resolving deltas: 100% (115/115), completed with 29 local objects.
From https://github.com/discourse/discourse_docker
   0b03a3c..88ee2e3  master     -> origin/master
 * [new branch]      auto       -> origin/auto
 * [new branch]      configurable-pg-sleep -> origin/configurable-pg-sleep
 * [new branch]      pg_ctl     -> origin/pg_ctl
 * [new branch]      systemd-swap-config -> origin/systemd-swap-config
Updating 0b03a3c..88ee2e3
Fast-forward
 discourse-setup                            | 158 ++++++++++++++++++++++++-----
 image/base/Dockerfile                      |  12 +--
 image/base/VERSION                         |   2 +-
 image/base/install-imagemagick             |   2 +-
 image/base/install-nginx                   |   2 +
 image/build.rb                             |   2 +-
 image/discourse/Dockerfile                 |   4 +-
 image/discourse_bench/Dockerfile           |   4 +-
 image/discourse_dev/Dockerfile             |   4 +-
 image/discourse_fast_switch/Dockerfile     |   4 +-
 image/discourse_test/Dockerfile            |   4 +-
 launcher                                   |  26 ++---
 samples/standalone.yml                     |  12 +--
 templates/web.letsencrypt.ssl.template.yml |   7 +-
 templates/web.ssl.template.yml             |  10 +-
 templates/web.template.yml                 |  13 +--
 16 files changed, 182 insertions(+), 84 deletions(-)

I thought that the web interface upgrade (which, as said, I did an hour ago) does all this git thing with it? Well, I’ll report with the results soon :slight_smile:


#4

Did rebuild. Sidekiq still giving

Jobs::UserEmail	{"type"=>"digest", "user_id"=>112, "current_site_id"=>"default"} Jobs::HandledExceptionWrapper: Wrapped SocketError: getaddrinfo: No address associated with hostname

I’ll leave it for now…


(Joshua Rosenfeld) #5

A site I set up at my previous job ran into that a month or so ago (and contacted me). Did some troubleshooting but never figured it out. Stopped occurring after a few days.


(Jeff Atwood) #6

Certainly looks like a DNS problem to me


(Matt Palmer) #7

Backtrace will tell you which name it’s failing on, and you can diagnose from there.