No admin email sent after 30 minute install

I have followed the instruction faithfully in discourse/ at master · discourse/discourse · GitHub

Including using Digital Ocean with default Ubuntu 16.04 LTS x64 but 2GB RAM (we’re optimistic!) and New York.

I have bought a new domain from Namecheap and set up an Email Provider - Elastic Email as recommended - and added valid SPF and DKIM records in DNS. I tested the SMTP server in Gmail (as an added email address) and have sent an email successfully.

The setup via SSH worked all fine and after the bootstrap completed Discourse appeared in the subdomain as expected. I am able to setup the account details but no email is received.

Following Troubleshooting email on a new Discourse install I made the from email address one that was registered with Elastic Email. Though why I should need to edit a configuration file for a standard install I don’t understand.

I have destroyed the droplet a number of times and started the whole process again as I followed the instructions more and more completely. I am still not receiving the confirmation email.

There appear to be errors with Redis not connected in shared/standalone/log/rails/production.log

Job exception: Error connecting to Redis on localhost:6379 (Errno::ECONNREFUSED)

but at the end of the bootstrapping there’s the following:

I, [2018-08-16T22:44:13.882857 #14] INFO -- : Terminating async processes

I, [2018-08-16T22:44:13.883096 #14] INFO -- : Sending INT to HOME=/var/lib/postgresql USER=postgres exec chpst -u postgres:postgres:ssl-cert -U postgres:postgres:ssl-cert /usr/lib/postgresql/10/bin/postmaster -D /etc/postgresql/10/main pid: 69

I, [2018-08-16T22:44:13.883392 #14] INFO -- : Sending TERM to exec chpst -u redis -U redis /usr/bin/redis-server /etc/redis/redis.conf pid: 185

2018-08-16 22:44:13.883 UTC [69] LOG: received fast shutdown request

185:signal-handler (1534459453) Received SIGTERM scheduling shutdown...

2018-08-16 22:44:13.885 UTC [69] LOG: aborting any active transactions

2018-08-16 22:44:13.891 UTC [69] LOG: worker process: logical replication launcher (PID 78) exited with exit code 1

2018-08-16 22:44:13.891 UTC [73] LOG: shutting down

2018-08-16 22:44:13.907 UTC [69] LOG: database system is shut down

185:M 16 Aug 22:44:13.911 # User requested shutdown...

185:M 16 Aug 22:44:13.911 * Saving the final RDB snapshot before exiting.

185:M 16 Aug 22:44:13.916 * DB saved on disk

185:M 16 Aug 22:44:13.917 # Redis is now ready to exit, bye bye...`

which is shutting down Redis, so I guess it’s not surprising that there’s an error message about not connecting to Redis.

So I am wondering what I can do to solve this?

1 Like

Well it finally worked. I changed the SMTP server settings back to the default 2525 port rather than the 25 that Gmail only let me use when I was testing.

However it only appears to have worked after editing the containers/app.yml configuration file and changed the from address.

Could this not be an option in the setup script?


I’m not sure what you’re asking.

./discourse-setup does prompt you for a port number. All you have to do is run ./discourse-setup again.

Perhaps it’s that

suggests that you need to edit the file by hand?

I changed it so now it reads:

Does that make it clearer?

While I was there, I also added:


DO have been known to block :25 outbound for droplets on new accounts. Elastic email does support TLS though.


Thanks @pfaffman for your helpful reply.

I was using the following instructions that seemed to be the solution:

I’m really asking if the ./discourse-setup will include an option for a default from address so the above editing of the containers/app.yml file is not necessary.

It’s definitely a help for beginners not to have any suggestions for editing in the command line!

That would’ve been very useful to see in my case :blush:

I tried a setup that I had tested and knew worked ie port 25 but I figured that it could be a problem so I went back to the port 2525 setting.