No image preview for large images


(James) #1

I have installed a new instance of discourse following the official discourse installation guide. When I create a post and upload a large image (say 1500x1200px) a thumbnail is created for the post, but when I hover over the image I get no option to click on it and view the full size image.

I am using v2.1.0.beta3 +64. I have the option “Create thumbnails and lightbox images that are too large to fit in a post.” enabled in settings.

I do have another instance of discourse used on a different domain (using version 2.1.0.beta3 +56) and the image preview works as expected. As far as I can tell, the settings between the two sites are identical.

The site that works is using Ubuntu 16.04 LTS, the site that is giving me issues is using Ubuntu 18.04 LTS, would this be part of the problem ?

Im not sure how to troubleshoot this problem, any advice welcome.

Thanks.


(Christoph) #2

The first thing I’d do is bring the two instances to the exact same discourse build. If there is still a difference between the two sites, chances are they’re related to 18.04. If the difference goes away, we know that some problem was introduced between v2.1.0.beta3 +56 and v2.1.0.beta3 +64.


(James) #3

Thanks for the advice.

Through a process of updating both sites to the same versions of discourse, and creating a new install using Ubuntu 16.04 LTS, the problem appears to be related to Ubuntu 18.04 LTS. When I create a site using Ubuntu 18.04 LTS image previews for large images will not work for me, using Ubuntu 16.04 LTS doesn’t give me this issue.

Thanks for the advice @tophee


Any reason NOT to use Ubuntu 18.04 LTS Minimal image?
(Dan) #4

I can re-produce this on my own Live Forum.
Same using Ubuntu 18.04.1.

2000x1990 image just open on new Tab.
1523x999 open just fine on lightbox.

Edit :D.
2000x1990 image just open on new Tab because it isn’t attached.
Now that I uploaded it as attachment, works as expected.