No matter what I do, can't get email working on new install


(James Daly) #1

I’m sorry to ask yet another question, I’m doing my best to solve this myself, as I know beginner questions can be annoying (I’ve been reading through this excellent page here Troubleshooting email on a new Discourse install) but no matter what I try I don’t receive an email to set up the admin account :frowning:

I’m not receiving the confirmation email when setting up. I must have made a mistake when setting up my email, but for the life of me I can’t figure out what it is. Perhaps something to do with the domain vs subdomain with my mail provider.

I’ve set up forum@invincibletricking.co with my domain name company, forwarding it to my usual email account, and have put these details into Spark Post.

I receive standard emails sent to forum@invincibletricking.co, so the forwarding address itself works.

Have configured Spark Post as set out in the instructions, and then entered it all into the app.yml file:

## TODO: List of comma delimited emails that will be made admin and developer
## on initial signup example 'user1@example.com,user2@example.com'
DISCOURSE_DEVELOPER_EMAILS: 'forum@invincibletricking.co'

## TODO: The SMTP mail server used to validate new accounts and send   notifications
DISCOURSE_SMTP_ADDRESS: smtp.sparkpostmail.com
DISCOURSE_SMTP_PORT: 587
DISCOURSE_SMTP_USER_NAME: SMTP_Injection
DISCOURSE_SMTP_PASSWORD: b625 ••••••••••••••••••••••••••••••••••••
#DISCOURSE_SMTP_ENABLE_START_TLS: true           # (optional, default true)

And in Spark Post SMTP Relay settings on their site:

SMTP Relay

Use the information below to configure your SMTP client to relay via SparkPost.
You need an API key to use as a password when filling out the information.
**Host:**smtp.sparkpostmail.com
**Port:**587 (Alternative Port: 2525)
**Authentication:**AUTH LOGIN
**Encryption:**STARTTLS
**Username:**SMTP_Injection
Password: b625 ••••••••••••••••••••••••••••••••••••

Verified sending domain panel screenshot from Spark Post is here: http://conversantm.com/68pl/2g3lj9931

And the URL of my forum is a subdomain of https://invincibletricking.co

It’s doing my head in haha hoping you’ll be able to help a learner like myself out :innocent:


(Orry Messer) #2

I can’t access the password on SparkPost either. It also only shows me the first four characters of the password. I can’t find a way to view it in its entirity :frowning:

Sadly, I can’t pass the SPF test either. The DKIM is fine though


(Orry Messer) #3

Alright. So I made a silly mistake. After they show you the key you can’t see it again. So I’m just going to make a new key with the same permissions and this time I’ll note what the key is. Very noob mistake. Maybe this is also your mistake?