None of the plugins on my site are working because I pinned to a five month old version


#1

None of the plugins on my site are working after I resized my droplet

I did ./launcher rebuild app - twice - but made no difference.

I tried disabling and enabling the plugin - still no difference.

What could be wrong?
There are tons of errors in site.com/log

Example error from log

Error: Could not find module discourse/lib/push-notifications imported from discourse/plugins/discourse-push-notifications/discourse/initializers/setup-push-notifications


(cpradio) #2

Can you provide any of the errors? I am also assuming you made your droplet larger, not smaller, but details would be helpful.

Are all the errors the same?

What version of Discourse are you on? What branch are you following (tests-passed, stable, beta)?


#3

I’m on this branch

version: 6dad7dfcec5407d5ed1c526b6191b5c2e4153a39

Actually I moved from dedicated 4 CPU cores to shared 4 cpu cores.
So, RAM still remains at 8GB, and CPU goes to 4 shared instead of 4 dedicated.

($80 per month to $40 per month droplet)

Error log sample

Error: Could not find module `discourse/lib/push-notifications` imported from `discourse/plugins/discourse-push-notifications/discourse/initializers/setup-push-notifications`
    at o (https://sitename.com/assets/ember_jquery-a8dcbd325e04410f036f2a791d66d8316c48c5387acdd914de99a5dd6afb3cd3.js:19:10578)
    at i (https://sitename.com/assets/ember_jquery-a8dcbd325e04410f036f2a791d66d8316c48c5387acdd914de99a5dd6afb3cd3.js:19:10417)
    at n.state (https://sitename.com/assets/ember_jquery-a8dcbd325e04410f036f2a791d66d8316c48c5387acdd914de99a5dd6afb3cd3.js:19:12063)
    at e (https://sitename.com/assets/ember_jquery-a8dcbd325e04410f036f2a791d66d8316c48c5387acdd914de99a5dd6afb3cd3.js:19:9876)
    at require (https://sitename.com/assets/ember_jquery-a8dcbd325e04410f036f2a791d66d8316c48c5387acdd914de99a5dd6afb3cd3.js:19:12048)
    at https://sitename.com/assets/application-a35601a204538cc2f69c71783bcc7324bd02636784b9fa4655ff19612832bda4.js:4:28685
    at Array.forEach (<anonymous>)
    at start (https://sitename.com/assets/application-a35601a204538cc2f69c71783bcc7324bd02636784b9fa4655ff19612832bda4.js:4:28628)

(cpradio) #4

Okay, so you are forcing Discourse (core) to be on a commit done in January, but your plugins are moving forward and getting up-to-date changes. This seems like a really bad idea.

Any chance you can attempt to rebuild pointing to tests-passed?


#5

I think doing so, my site may break.

I think the push notification plugin is creating issue.
I’ve just removed it, rebuild in progress…


(cpradio) #6

Well, yes, that is an option too.

Why?
What else do you have that isn’t “latest” friendly?


(Jeff Atwood) #7

We are not going to support you, when you have force pinned Discourse to a five month old version.

You’ve created this problem yourself – you should also solve it yourself.


#8

Nothing much, just worried, about the site design. But if disabling push notification plugin is not working - then I think I will end up updating to latest discourse. I’m left with no other options.