Not able to restore the backup

I have the backup of my old discourse forum that I deleted some months ago, but I kept its backup.

Yesterday, I installed a new discourse forum and tried to restore the same backup of my old discourse forum. But it got failed, I tried many times but same error.

Here is what logs says:

EXCEPTION: lib/discourse.rb:92:in `exec’: Failed to decompress archive.

1 Like

it seems that your backup is corrupt

3 Likes

But I had downloaded the backup using the official way through my discourse forum

1 Like

You can try to uncompress it yourself.

1 Like

Then, how can I upload that in discourse? Can you explain it a bit more.

When you try to uncompress it, does it work? I’m guessing no. If you can uncompress it, then I don’t have an idea. There are many ways that a fire can get corrupted. The best bet is that yours is.

1 Like

I can easily compress it on my computer but when uploading, it got failed. Same error every time.

What is the filename of your backup (including extension) ?

If you decompress the backup on your computer, what files do you see?

1 Like