Odd files size setting


(Khoa Nguyen) #1

My files setting are : (I want member can upload a file up to 20MB)

But when I upload a 7 MB PDF file. It said that file is too large (maxium file size is 3072 kb).
I set max image size kb to 20480 and reupload that file. It said that file is too large (maxium file size is 20480 kb) ???

How can I adjust these setting? (nginx client_max_body_size is 30m )


(Jeff Atwood) #2

If you check the howto section (or scope your search to howtos) there is an advanced howto that covers how to change the upload limit in nginx.


(Khoa Nguyen) #3

I set nginx limit up to 30m. But I can’t upload large file.
@sam here is a screencast :

Any files larger than 3 MB will cause this error.


(Mittineague) #4

The error message does suggest a size error, but did you try giving a Title and some text content as well as the drag-drop?

Have you tried using the composer’s “attach” instead of drag-drop? Copy-paste?


(Khoa Nguyen) #5

In the screencast, I drap and drop a 3.5 MB file but the suggest size is 20480 kb (20MB)
Composer’s “attach” or Copy-paste have the same error.

@Mittineague


(Mittineague) #6

I’m wondering if not having title or text triggered the error, but you got the size error message.


(Khoa Nguyen) #7

Ah. I did wrote some content as well. I know about this error when I writing a very long post.


(Khoa Nguyen) #8

@sam can you help me with this please? I update to the latest, rebuild app… But I can upload any file larger then 3 MB.