Onebox: Hyperlinks in tweets are not clickable


#1

On digitalocean, ubuntu 14.04.3 LTS
Fresh docker install according to the 30-min guide.
Logged in as admin, posted a link to a tweet and it shows as this:

I wiped my test installation and tried from scratch, no difference…

The hyperlink in the tweet is not clickable. Here on Meta it works.

Does anyone have an idea what it might be?

Thanks!


(Joshua Rosenfeld) #2

Can you share the link to the post where you attempted this?


#3

Sure, here:

http://test.bmblinks.com/t/another-twitter-test/13


(Joshua Rosenfeld) #4

Hmm, that is indeed odd. It sure does work here on meta:

Interestingly the URL is changed from blog.discourse… to t.co

It looks like you are on the latest version of Discourse, so I have no idea what might be causing this. Sorry!


(Sam Saffron) #5

I recall we have two expanders one with api key and one without, @techAPJ can you have a look if one without Twitter api creds is good?


(Dave McClure) #6

I’m having the same issue as the OP on our site, but not here. Is there something we need to configure in site settings to get hyperlinks in twitter oneboxes?


(Jeff Atwood) #7

You must enable Twitter logins to set up the twitter API. Weird things about twitter oneboxing depend on this.


(Kane York) #8

Actually… you need to fill out the api consumer key / secret fields but turning on login is not required.

So yeah, follow the twitter logins #howto and just don’t turn on the “enable twitter logins” setting.