# Oops error

**URL:** https://meta.discourse.org/t/oops/399614
**Category:** Support
**Created:** [March 31, 2026, 8:15am UTC](https://meta.discourse.org/t/oops/399614 "2026-03-31T08:15:28Z")
**Posts on this page:** 13
**Page:** 1

<div class="post-metadata">

### Author: ![singi2016cn](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/singi2016cn/32/532755_2.png) [@singi2016cn](https://meta.discourse.org/u/singi2016cn)
#### Post date: [March 31, 2026, 8:15am UTC](https://meta.discourse.org/t/oops/399614/1 "2026-03-31T08:15:28Z")

</div>

I rebuilt my website, and when I opened the browser, I saw the following message:

```plaintext
Oops
The software powering this discussion forum encountered an unexpected problem. We apologize for the inconvenience.

Detailed information about the error was logged, and an automatic notification generated. We'll take a look at it.

No further action is necessary. However, if the error condition persists, you can provide additional detail, including steps to reproduce the error, by posting a discussion topic in the site's feedback category.

```

> I remember that before this issue appeared, I clicked on the AI plugin configuration page.

For the `containers/app.yml` file, I only added the following at the end:

```plaintext
params:
  version: esr

```

Now I’ve tried rebuilding multiple times, but every time I refresh, I get this error message.

Has anyone encountered this issue?

---

<div class="post-metadata">

### Author: ![gilles](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/gilles/32/549022_2.png) [@gilles](https://meta.discourse.org/u/gilles)
#### Post date: [March 31, 2026, 8:31am UTC](https://meta.discourse.org/t/oops/399614/2 "2026-03-31T08:31:33Z")

</div>

Remove your changes from your app.yml file

and run ./launcher rebuild app

You likely have a syntax error in your file

Now, I’m not a specialist, so I don’t know if what you did in your app.yml file is correct, but to get your forum running again as quickly as possible, remove your changes and run a rebuild.

---

<div class="post-metadata">

### Author: ![singi2016cn](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/singi2016cn/32/532755_2.png) [@singi2016cn](https://meta.discourse.org/u/singi2016cn)
#### Post date: [March 31, 2026, 8:33am UTC](https://meta.discourse.org/t/oops/399614/3 "2026-03-31T08:33:17Z")

</div>

Thanks for your answer, but the issue probably isn’t with app.yml, since I’ve successfully built this app.yml many times before.

---

<div class="post-metadata">

### Author: ![singi2016cn](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/singi2016cn/32/532755_2.png) [@singi2016cn](https://meta.discourse.org/u/singi2016cn)
#### Post date: [March 31, 2026, 8:34am UTC](https://meta.discourse.org/t/oops/399614/4 "2026-03-31T08:34:18Z")

</div>

After running the commands below, the homepage was restored, but clicking “Log In” triggered the Oops error again.

```bash
redis-cli flushall

sv restart unicorn

sv reload nginx

```

---

<div class="post-metadata">

### Author: ![david](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/david/32/157490_2.png) [@david](https://meta.discourse.org/u/david)
#### Post date: [March 31, 2026, 8:37am UTC](https://meta.discourse.org/t/oops/399614/5 "2026-03-31T08:37:46Z")

</div>

Did you downgrade your site from `latest` to `esr`? That would explain this kind of error.

---

<div class="post-metadata">

### Author: ![singi2016cn](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/singi2016cn/32/532755_2.png) [@singi2016cn](https://meta.discourse.org/u/singi2016cn)
#### Post date: [March 31, 2026, 8:41am UTC](https://meta.discourse.org/t/oops/399614/6 "2026-03-31T08:41:56Z")

</div>

Maybe it’s a downgrade issue. I redeployed this server a few weeks ago while testing features for a specific version, but I now believe ESR is the best practice. Then I ran into this Oops.

> However, it was running smoothly for several weeks before, and suddenly started throwing errors just now.

How can I resolve this? Is upgrading to the latest version the only option?

---

<div class="post-metadata">

### Author: ![david](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/david/32/157490_2.png) [@david](https://meta.discourse.org/u/david)
#### Post date: [March 31, 2026, 8:57am UTC](https://meta.discourse.org/t/oops/399614/7 "2026-03-31T08:57:36Z")

</div>

Unfortunately downgrading is not supported. So yes, you’ll either need to restore an earlier backup from when you were running ESR, or you’ll need to run `latest` until the next ESR release (July)

---

<div class="post-metadata">

### Author: ![singi2016cn](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/singi2016cn/32/532755_2.png) [@singi2016cn](https://meta.discourse.org/u/singi2016cn)
#### Post date: [March 31, 2026, 9:00am UTC](https://meta.discourse.org/t/oops/399614/8 "2026-03-31T09:00:51Z")

</div>

Do you mean the issue is caused by a conflict between the data and the code? Am I limited to reverting to the code version that matches my data?

---

<div class="post-metadata">

### Author: ![david](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/david/32/157490_2.png) [@david](https://meta.discourse.org/u/david)
#### Post date: [March 31, 2026, 9:01am UTC](https://meta.discourse.org/t/oops/399614/9 "2026-03-31T09:01:39Z")

</div>

Yes, exactly. The database schema is changed regularly. So if your database schema has already been updated to `latest`, it will be incompatible with the older code on ESR.

---

<div class="post-metadata">

### Author: ![singi2016cn](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/singi2016cn/32/532755_2.png) [@singi2016cn](https://meta.discourse.org/u/singi2016cn)
#### Post date: [March 31, 2026, 9:06am UTC](https://meta.discourse.org/t/oops/399614/10 "2026-03-31T09:06:10Z")

</div>

So, if I install a new server, since the default standard installation is the latest version, attempting to deploy ESR at this point could lead to this issue.

If it’s an older server with a version like 3.5.0, upgrading to ESR should work without problems, correct?

---

<div class="post-metadata">

### Author: ![singi2016cn](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/singi2016cn/32/532755_2.png) [@singi2016cn](https://meta.discourse.org/u/singi2016cn)
#### Post date: [March 31, 2026, 9:07am UTC](https://meta.discourse.org/t/oops/399614/11 "2026-03-31T09:07:41Z")

</div>

Alternatively, I could delete all the data and then deploy the ESR version, which should also work.

This scenario applies when the data is inconsequential or on a newly deployed server that hasn’t generated any data yet. It will result in the loss of all data, so please proceed with caution!!!

Here are the specific steps:

```plaintext
# Delete the mount directory
rm -rf /var/discourse/shared/standalone

# Destroy the old container (I'm not sure if this step is necessary)
./launcher destroy app

# Modify app.yml, then rebuild the container
./launcher rebuild app

```

---

<div class="post-metadata">

### Author: ![david](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/david/32/157490_2.png) [@david](https://meta.discourse.org/u/david)
#### Post date: [March 31, 2026, 9:08am UTC](https://meta.discourse.org/t/oops/399614/12 "2026-03-31T09:08:11Z")

</div>

Yes, that’s all correct 👍

---

<div class="post-metadata">

### Author: ![system](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/system/32/443519_2.png) [@system](https://meta.discourse.org/u/system)
#### Post date: [April 30, 2026, 9:09am UTC](https://meta.discourse.org/t/oops/399614/13 "2026-04-30T09:09:00Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
