Out of disk space but server has 600 GB free


(Saurek) #1

I reconfigured my mail servers today and when I recompiled my app I keep getting a failure saying insufficient disk space. I have checked and do have sufficient disk space.

I have also run the launcher cleanup command and apt autoclean.

Not sure what to do :o


(Jeff Atwood) #2

Add more disk space to your server?

If you have done autoclean and launcher cleanup that is about it.


(Saurek) #3

Jeff, I have 600GB free.


(Jeff Atwood) #4

Oh I see, so you believe there is a bug in the rebuild script? On what OS?


(Rafael dos Santos Silva) #5

Is it on the same partition that docker store his aufs filesystem? And where the shared volumes are mounted? Both have 600GB to spare?

Can you share a df -h ?


(Saurek) #6

Ubuntu 16.04, I ran into this issue once before and fixed it by just rebooting the box and rebuilding. However, I have other important servers running on this box so I cannot do a hard reboot at this time.


(Saurek) #7

Yes @falco it’s on the correct FS


(Julian Muñoz) #8

Maybe you ran out of inodes?

df -ih


(Saurek) #9

Only using 34% on this FS


(Matt Palmer) #10

Without full details of your system, such as the complete output of df -h, df -ih, the full logs from a failed rebuild, and probably a bunch of other things, you’re going to be on your own here. Psychic debugging is such a tiresome process.


(Saurek) #11

Lol so I just kept re running the rebuild app process over and over (about 10 times) and finally it worked. Rails is a strange beast.


(Jeff Atwood) #12

We’ve never seen such behavior, so I suspect something is amiss on your server.


(Saurek) #13

Possibly I don’t know, it’s just a stock server from OVH. I was having these issues back when the only thing installed was Discourse. I dunno, this docker & bundler inception is way over my head, other than these weird build problems everything works great though.

I’m really impressed with your commitment to support, thanks for offering to help.