# PEM\_read\_bio\_X509\_AUX() falhou (SSL: erro:0909006C:PEM routines:get\_name:no start line:Expecting: TRUSTED CERTIFICATE)

**URL:** <https://meta.discourse.org/t/pem-read-bio-x509-aux-failed-ssl-errorpem-routinesno-start-line-trusted-certificate/176546>\
**Category:** Self-hosting\
**Created:** [Janeiro 19, 2021, 10:59am UTC](https://meta.discourse.org/t/pem-read-bio-x509-aux-failed-ssl-errorpem-routinesno-start-line-trusted-certificate/176546 "2021-01-19T10:59:08Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![yoko](https://avatars.discourse-cdn.com/v4/letter/y/58956e/32.png) [@yoko](https://meta.discourse.org/u/yoko)\
**Post date:** [Janeiro 19, 2021, 10:59am UTC](https://meta.discourse.org/t/pem-read-bio-x509-aux-failed-ssl-errorpem-routinesno-start-line-trusted-certificate/176546/1 "2021-01-19T10:59:09Z")

</div>

Tentei configurar um fórum usando o Discourse no Ubuntu 20.04 LTS em um VPS. Mas, após a instalação, recebo:

```plaintext
nginx: [emerg] não foi possível carregar o certificado "/shared/ssl/domain.org.cer": PEM_read_bio_X509_AUX() falhou (SSL: error:0909006C:PEM routines:get_name:no start line:Expecting: TRUSTED CERTIFICATE)
nginx: teste de arquivo de configuração /etc/nginx/nginx.conf falhou

```

Meu domínio é:

Executei este comando:

> sudo nginx -t

Ele produziu esta saída:

> ```plaintext
> nginx: [emerg] não foi possível carregar o certificado "/shared/ssl/domain.org.cer": PEM_read_bio_X509_AUX() falhou (SSL: error:0909006C:PEM routines:get_name:no start line:Expecting: TRUSTED CERTIFICATE)
> 
> ```

nginx: teste de arquivo de configuração /etc/nginx/nginx.conf falhou

> ```plaintext
> 
> ```

Meu servidor web é (inclua a versão):

> nginx version: nginx/1.18.0

Devo criar um certificado? Isso aparece depois que clonei o repositório mais recente do GitHub. Esse é um comportamento desejado?

---

<div class="post-metadata">

**Author:** ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)\
**Post date:** [Janeiro 19, 2021, 1:19pm UTC](https://meta.discourse.org/t/pem-read-bio-x509-aux-failed-ssl-errorpem-routinesno-start-line-trusted-certificate/176546/2 "2021-01-19T13:19:52Z")

</div>

Se você fez uma [Instalação Padrão Oficial do Discourse](https://meta.discourse.org/t/discourse-official-standard-installation/142537) e apagou tudo, reiniciando várias vezes, atingiu o limite de taxa do Let’s Encrypt e não conseguirá obter um certificado por uma semana. Você pode contornar isso seguindo o guia [Configurando o Let’s Encrypt com Múltiplos Domínios](https://meta.discourse.org/t/setting-up-let-s-encrypt-with-multiple-domains/56685) e adicionando outro domínio ao site. Também poderia simplesmente usar um nome diferente ou aguardar uma semana.

---

<div class="post-metadata">

**Author:** ![yoko](https://avatars.discourse-cdn.com/v4/letter/y/58956e/32.png) [@yoko](https://meta.discourse.org/u/yoko)\
**Post date:** [Janeiro 19, 2021, 2:35pm UTC](https://meta.discourse.org/t/pem-read-bio-x509-aux-failed-ssl-errorpem-routinesno-start-line-trusted-certificate/176546/3 "2021-01-19T14:35:43Z")

</div>

Então, uma semana (7 dias) é o tempo que devo esperar para configurar tudo novamente?

---

<div class="post-metadata">

**Author:** ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)\
**Post date:** [Janeiro 19, 2021, 5:06pm UTC](https://meta.discourse.org/t/pem-read-bio-x509-aux-failed-ssl-errorpem-routinesno-start-line-trusted-certificate/176546/4 "2021-01-19T17:06:49Z")

</div>

Essa é a minha melhor suposição com base no que você descreveu.

---

<div class="post-metadata">

**Author:** ![yoko](https://avatars.discourse-cdn.com/v4/letter/y/58956e/32.png) [@yoko](https://meta.discourse.org/u/yoko)\
**Post date:** [Janeiro 19, 2021, 5:08pm UTC](https://meta.discourse.org/t/pem-read-bio-x509-aux-failed-ssl-errorpem-routinesno-start-line-trusted-certificate/176546/5 "2021-01-19T17:08:12Z")

</div>

Ok, vamos esperar. Vou postar depois se funcionar.

---

<div class="post-metadata">

**Author:** ![oca](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/oca/32/156060_2.png) [@oca](https://meta.discourse.org/u/oca)\
**Post date:** [Janeiro 31, 2021, 2:39pm UTC](https://meta.discourse.org/t/pem-read-bio-x509-aux-failed-ssl-errorpem-routinesno-start-line-trusted-certificate/176546/6 "2021-01-31T14:39:13Z")

</div>

Para registro, tive o mesmo problema e a causa foi que esqueci de redirecionar a porta 80 para o servidor.

A verificação de DNS realizada pelo `discourse-server.sh` pode ser feita apenas na porta 443 e não detectou o problema.

No entanto, o Let’s Encrypt também precisa que a porta 80 esteja aberta.
