# PEM\_read\_bio\_X509\_AUX() 失败 (SSL: error:0909006C:PEM 例程:get\_name:no start line:Expecting: TRUSTED CERTIFICATE)

**URL:** <https://meta.discourse.org/t/pem-read-bio-x509-aux-failed-ssl-errorpem-routinesno-start-line-trusted-certificate/176546>\
**Category:** Self-hosting\
**Created:** [2021 年1 月 19 日 10:59 UTC](https://meta.discourse.org/t/pem-read-bio-x509-aux-failed-ssl-errorpem-routinesno-start-line-trusted-certificate/176546 "2021-01-19T10:59:08Z")\
**Posts on this page:** 1\
**Showing post:** 6

<div class="post-metadata">

作者： ![oca](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/oca/32/156060_2.png) [@oca](https://meta.discourse.org/u/oca)\
发布日期： [2021 年1 月 31 日 14:39 UTC](https://meta.discourse.org/t/pem-read-bio-x509-aux-failed-ssl-errorpem-routinesno-start-line-trusted-certificate/176546/6 "2021-01-31T14:39:13Z")

</div>

说明一下，我也遇到过同样的问题，原因是我忘记将 80 端口重定向到服务器。

`discourse-server.sh` 执行的 DNS 检查可能仅在 443 端口进行，因此未能检测到该问题。

但 Let’s Encrypt 也需要 80 端口处于开放状态。

---

_[View the full topic](https://meta.discourse.org/t/pem-read-bio-x509-aux-failed-ssl-errorpem-routinesno-start-line-trusted-certificate/176546)._
