Pending post, can't find where to approve


(Erik Manger) #1

Hi,

I have a brand new Discourse install. I made a topic and it said it’s pending approval.

The hamburger icon has a red 1 beside it but when I click it I do not know where else to go. How do I approve my post? Also, can I disable this feature?

Thanks in advance.


(Stephanie) #2

I don’t know how to approve, but I think I found where to disable that.

Settings->Posting
Scroll all the way down, there are options about approving posts.


(Jeff Atwood) #3

There should be a pending posts menu item in the hamburger where the red circle number was.


(Erik Manger) #4

I’m running the latest update, no pending option is shown. I am full-admin.

Also,


Is this a glitch?


(Erik Manger) #5

@codinghorror

Hello? Is this an issue?


(Raymond) #6

When you have a post to approve it appears in your notifications feed. It has an arrow pointing left, the username that posted it and the subject of their post. When you click that it takes you to the place in settings to approve it quickly.

I’m assuming you mean finding that place without using that link is difficult because I’ve fumbled around a few times looking for it when I didn’t have the notification available.

Ray


(Erik Manger) #7

I posted two topics and never got notifications to approve them at all.

The system does not either show the pending posts via notification. I think this is a glitch. Can I just get rid of post approval?


(Raymond) #8

Yes, it is inside the admin panel | settings | posting.

Ray


(Erik Manger) #9

I don’t see how to disable it on that page.

Also, I can’t find where to approve posts from the drop down menu…

Please help :frowning:


(Jeff Atwood) #10

Are you on latest? Any ideas @eviltrout?


(Erik Manger) #11

I found the issue, yes I am on the latest update!

Originally, my approve post count was set to 0. I set it to 3 and now the “needs approval” tab shows.

Is it a potential glitch? The system originally said I had posts needing approval, but since I had the settings set to 0 - the tab didn’t show. The tab showed once I set the approval amount to 3.


(Mittineague) #12

To me, if the setting
number of posts that need to be approved = "none"
then none need to be approved.

At least it makes sense to me.
Maybe you can suggest a change in the copy that would have made things clearer for you?


(Raymond) #13

It is the 2nd from the last option, amount of new posts that must be
approved for new users. Change it to 0 and save.


(Robin Ward) #14

Yes I had complaints that people didn’t like seeing the menu item when posts didn’t need to be approved. So it is hidden if you set it to 0.


(Erik Manger) #15

The problem with that is, my discourse instance said posts needed approval but the tab was hidden - so that’s definitely an issue. If the tab is hidden and posts need approval, how would a new user of the software know that?


(Robin Ward) #16

It’s a bit of an edge case to enable approval, let something queue up for approval than disable it though. In that case you can re-enable it, approve the post(s) and then disable it again.


(Allen - Watchman Monitoring) #17

maybe it’s best not to allow moderation to be disabled if there are pending posts?


(Allen - Watchman Monitoring) #18

While testing my “moderator needs approval” issue, I ran into this issue:

As soon as a post needed approval, I saw the red 1 in the admin sandwich menu.

I clicked on it, but Needs Approval wasn’t there.
I could only see the needed menu item after refreshing the page.

Please have the Needs Approval menu item show up on demand?
Also, if previous approvals are kept for a period of time for purposes of Undo, maybe the menu item should be there all the time?


(Jeff Atwood) #19

It is basically unsupported to switch the approval site setting on and off willy-nilly. Not sure if @eviltrout anticipated a use case where this value will change every few seconds.

I do know he made it so that if there are any posts left in a pending approval state, the hamburger menu will be forced on regardless of the site settings; too many people were somehow turning off approval with posts in a pending approval state.


(Robin Ward) #20

Yes I made this change to prevent confusion.

You might have to refresh the page to see it if you see the (1) and no “Needs Approval”. But it is fixed in the latest stable.