Permission to invite users on private site


(Kalvin Greis) #1

Hi,

I’ve set up a new discourse community which I’ve invited several family members to. I’d like them to be able to invite other people as well. Although the “invite” button appears for me, as an administrator, it does not appear for the family members I’ve invited.

I have made them moderators, and they appear in both the “trust_level_3” group and the “staff” group, but they still have no “invite” button. (I’ve seen it on their own screens, and I’ve used the impersonate feature).

Is there a setting I may have selected that interfered with the desired behavior?

Thanks for any help you can provide! Love the software!


(James Milligan) #2

Have you got enable local logins ticked?


(Khoa Nguyen) #3

I have this problem too :).
@lake54 enable local logins ticked.


(Kalvin Greis) #4

Yes, these are all checked:

Invite only.
Login required.
Must approve users.
Enable local logins.
Allow new user registrations.


(Jeff Atwood) #5

I think approval is the problem here. Invites means one-click join, no approval process. So if you have approval enabled, you have by definition ruled out invites.


Allowing members to invite in a 'must approve users' forum
(Kalvin Greis) #6

Okay, I unchecked the “must approve users” box so now I have these checked:

Invite only.
Login required.
Enable local logins.
Allow new user registrations.

Doesn’t work when I use the “impersonate” feature on this user, for example:


(Jeff Atwood) #7

Yeah something odd is going on there, staff should be able to invite. Are you looking for the invite button on their user page, or at the bottom of topics?


(Kalvin Greis) #8

The bottom of a thread. My user account (an admin) sees it. Other people don’t.