Please require the fast_stack gem, note flamegraph is only supported on Ruby 2.0 and above


(Dean Taylor) #1

I’m currently seeing the message Please require the fast_stack gem, note flamegraph is only supported on Ruby 2.0 and above when rebuilding via:

cd /var/discourse
git pull
./launcher rebuild app
== Seed from /var/www/discourse/db/fixtures/999_topics.rb

I, [2016-05-15T00:54:42.867594 #38]  INFO -- : > cd /var/www/discourse && su discourse -c 'bundle exec rake assets:precompile'
Please require the fast_stack gem, note flamegraph is only supported on Ruby 2.0 and above
I, [2016-05-15T00:54:57.115158 #1032]  INFO -- : Writing /var/www/discourse/public/assets/vendor-6c83cefb781b3fa325bff76e9ba637bf719260cc7353ee0179cd706e79535999.js

Is the gem fast_stack missing from the base image / Discourse ?


(Sam Saffron) #2

yeah I got to sort this out, probably going to simply hold off cause 2.3.1 based image is queue for next week