Continuing the discussion from Rails Girls SoC Banter:
Some good points have been brought up.
Though it is possible to name a property something like “enable” where it actually disables when the value is true without breaking the code, it sure could be confusing to others and self after the code has grown cold. AFAIK there is no “rule” in this regard, but descriptive naming is a very good idea.
In that vien, re “discourse-___"
It seems logical to have “discourse” in a plugin name as that is what it works with. (there’s descriptive naming again) - BUT- I know when I wrote some WordPress plugins a few years ago I got in the habit of prefixing my class / function names with "mittineague” to prevent the possibility of conflicts.
So, for example, instead of my naming a plugin
I could name it
More verbose, true, but as the number of Discourse plugins is growing, maybe doing similar is a good idea?