PM from your user profile tries to send PM to you


(Apparently Archetype) #1

Trying to send a PM from anywhere in your user profile tries to send the PM to you, unsuccessfully.

##Repos on:

##Steps to reproduce:

  1. Visit one of the links above to view your profile
  2. Click an avatar (that isn’t you) to open their user card
  3. Click Private Message to start composing a private message to that user.

##Expected Results
The PM composer would open on clicking private message in an open user card with the PM addressed to that user.

##Actual results
On click the PM composer opens addressed to you, the active user, not the user whose usercard you had open and clicked private message.


(Apparently Archetype) #2

Additional, oddity. Attempting to send the PM created this way, without replacing your username with that of the intended target raises this error:

I get that sending a PM to yourself is a very odd thing to do, and i even get that there are reasons for it not to be supported, but that error message just looks… off to me.


(Mittineague) #3

Confirmed reproduced also for “bookmarked” and “replies”.
I guess not many have tried sending PMs from avatars in their Proflle lists.

Maybe easier to simply remove the User Card from the lists?


(Sam Saffron) #4

Confirmed bug, @eviltrout can you have a look?


#5

That unhelpful error message also appears when you set no recipient:


(Jeff Atwood) #6

Are you sure your friends don’t call you “Archetype”?


(Apparently Archetype) #7

They haven’t to date, not that i’d object.

the error message isn’t really a bug (that’s why i didn’t open separate thread) more of an awkward phrasing of an otherwise mostly helpful error message.


(Apparently Archetype) #8

Probably related: Also repro on @sam’s profile as myself

Following same steps as in the OP PM opens addressed to sam rather than the user whose usercard i had open (@codinghorror in this case)

Looks like the PM button is being overridden globally to crate a PM to the profile that is visible, including for usercards for a different user.


(Sam Saffron) #9

Looks like this was fixed as a side effect of one of our ember upgrades, flag to reopen if you can still repro somehow.


(Sam Saffron) #10