Port 443 Blocked on Discourse Digital Ocean and cloudfare

Are you hosting another site on the same server? If so, it is possible that the existing web server is blocking discourse from being able to bind to port 443. You may have to manually make changes to the app.yml file in addition to setting up the webserver to proxy requests to discourse to set up discourse along the existing webserver.

1 Like

Turn off the orange cloud

Edit: oops. Hard to the the image on my phone

1 Like

Not enabled for discourse I guess

1 Like

Another thing to try is double check that your DigitalOcean IP is correct: curl http://ip4.discourse.org/

1 Like

There is something running at 184.168.131.241 that does a redirect to shortener.secureserver.net. That’s why the test is failing. If that was running on that cost, discourse-setup should have noticed before it got this far, so it seems like 184.168.131.241 isn’t the IP of your droplet.

 wget --spider -Y off -O /dev/null -S -v bbs.happyendingspa.ca
Spider mode enabled. Check if remote file exists.
--2020-12-16 08:16:41--  http://bbs.happyendingspa.ca/
Resolving bbs.happyendingspa.ca (bbs.happyendingspa.ca)... 184.168.131.241
Connecting to bbs.happyendingspa.ca (bbs.happyendingspa.ca)|184.168.131.241|:80... connected.
HTTP request sent, awaiting response... 
  HTTP/1.1 302 Found
  Server: nginx/1.16.1
  Date: Wed, 16 Dec 2020 16:16:41 GMT
  Content-Type: text/html; charset=utf-8
  Connection: close
  Location: https://shortener.secureserver.net/error_404
Location: https://shortener.secureserver.net/error_404 [following]
Spider mode enabled. Check if remote file exists.
--2020-12-16 08:16:41--  https://shortener.secureserver.net/error_404
Resolving shortener.secureserver.net (shortener.secureserver.net)... 45.40.140.1
Connecting to shortener.secureserver.net (shortener.secureserver.net)|45.40.140.1|:443... connected.
HTTP request sent, awaiting response... 
  HTTP/1.1 404 Not Found
  Server: nginx/1.16.1
  Date: Wed, 16 Dec 2020 16:16:41 GMT
  Content-Type: text/html; charset=utf-8
  Connection: keep-alive
Remote file does not exist -- broken link!!!
2 Likes

It is working now after I updated the ip same with the droplet ip address,

but the email server is not working