Port 80 is showing up next to my domain in emails


(Marcelo Delgado) #1

I am using the Discourse install from Bitnami. Originally the links on the emails were showing my site’s ip + port. Then I followed info on this thread and updated the hostname on discourse.conf and database.yml from my ip to my domain. Now I have https://mydomain.com:80/users/password-reset/7e26c022e4caa527b133ed7a0f1fed3d links.

How can I get rid of that port?


(Varun) #2

I had this issue with the emails in my Bitnami install too, and managed to solve it by going to the admin settings and clearing the ‘port’ field under the Developer tab.


(Sam Saffron) #3

Agree with you there, seems likely that port is set to 80 and the warning is being ignored:

 DEVELOPER ONLY! WARNING! Use this HTTP port rather than the default of port 80. Leave blank for default of 80.

(Marcelo Delgado) #4

That did it thanks. Indeed, this was pre-filled on the Bitnami image.