Post creation fails when body has link


(Erica) #1

When our users post links to various external websites/resources, the post endpoint gives us an error “Sorry you cannot post a link to that host”

I’m trying to understand what is happening here and how I can remove the restriction. We’ve looked through the settings and I don’t see anything related.

Thanks!


(Rafael dos Santos Silva) #2

The min trust to post links setting default to trust_level_0. Have you changed that?


(Erica) #3

It’s set to 0 currently


(Jeff Atwood) #4

It sounds like you have blacklisted domains in your Admin, Logs, Watched Words perhaps?


(Erica) #5

We haven’t added anything along those lines. Any other ideas? I really appreciate your help with this.


(Kris) #6

I think that error message is specific to the newuser spam host threshold setting? The default is 3, so it would be triggered by a new user posting a link to the same domain 3 times and then being considered spam.

You can add domain(s) to the white listed spam host domains if there’s a specific domain you want to prevent the behavior for. You could also increase the default to higher than 3, but it would make it a bit easier for spammers.