Postfix "lost connection after CONNECT"

email
docker

#1

I’m running a private Discourse install inside a Docker container on my server. The Docker container is configured as such:

DISCOURSE_SMTP_ADDRESS: mail.example.com
DISCOURSE_SMTP_PORT: 587
DISCOURSE_SMTP_USER_NAME: discourse@example.com
DISCOURSE_SMTP_PASSWORD: [hidden]
DISCOURSE_SMTP_ENABLE_START_TLS: true
DISCOURSE_SMTP_AUTHENTICATION: login

The system is capable of sending e-mails through the server, but the following log is showing:

Message

Job exception: 220 www.example.com ESMTP Postfix (Ubuntu)

Backtrace

/usr/local/lib/ruby/2.0.0/net/pop.rb:1000:in `check_response'
/usr/local/lib/ruby/2.0.0/net/pop.rb:893:in `initialize'
/usr/local/lib/ruby/2.0.0/net/pop.rb:562:in `new'
/usr/local/lib/ruby/2.0.0/net/pop.rb:562:in `do_start'
/usr/local/lib/ruby/2.0.0/net/pop.rb:530:in `start'
/var/www/discourse/app/jobs/scheduled/poll_mailbox.rb:88:in `poll_pop3'
/var/www/discourse/app/jobs/scheduled/poll_mailbox.rb:18:in `execute'
/var/www/discourse/app/jobs/base.rb:153:in `block (2 levels) in perform'

Env

current_db: default
current_hostname: www.example.com
job: Jobs::PollMailbox
problem_db: default

opts:

/var/log/mail.log on the server gives more info:

discourse postfix/smtpd[4837]: connect from unknown[172.17.0.1]
discourse postfix/smtpd[4837]: lost connection after CONNECT from unknown[172.17.0.1]
discourse postfix/smtpd[4837]: disconnect from unknown[172.17.0.1]

I am unsure what this problem is, or how to fix it. Can you please advise?