# PostgreSQL 15 update

**URL:** <https://meta.discourse.org/t/postgresql-15-update/349515>\
**Category:** Announcements\
**Created:** [January 29, 2025, 7:20am UTC](https://meta.discourse.org/t/postgresql-15-update/349515 "2025-01-29T07:20:00Z")\
**Posts on this page:** 1\
**Showing post:** 111

<div class="post-metadata">

**Author:** ![henvo](https://avatars.discourse-cdn.com/v4/letter/h/dfb087/32.png) [@henvo](https://meta.discourse.org/u/henvo)\
**Post date:** [February 8, 2025, 6:56am UTC](https://meta.discourse.org/t/postgresql-15-update/349515/111 "2025-02-08T06:56:31Z")

</div>

During upgrade, I was getting

> Stopping PostgreSQL 15 database server: mainError: Config owner (postgres:101) and data owner (runit-log:999) do not match, and config owner is not root … failed!  
> failed!  
> could not open version file “/shared/postgres\_data/PG\_VERSION”: Permission denied  
> Failure, exiting

Which was solved by

> sudo ./launcher enter app

and then

> chown -R postgres:postgres /shared/postgres\_data  
> chown -R postgres:postgres /shared/postgres\_run  
> chmod -R 700 /shared/postgres\_data

---

_[View the full topic](https://meta.discourse.org/t/postgresql-15-update/349515)._
