# PostgreSQL update fails from China

**URL:** https://meta.discourse.org/t/postgresql-update-fails-from-china/350869
**Category:** Support
**Created:** [February 6, 2025, 10:58am UTC](https://meta.discourse.org/t/postgresql-update-fails-from-china/350869 "2025-02-06T10:58:57Z")
**Posts on this page:** 1
**Showing post:** 17

<div class="post-metadata">

### Author: ![mwaniki](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/mwaniki/32/313097_2.png) [@mwaniki](https://meta.discourse.org/u/mwaniki)
#### Post date: [February 6, 2025, 2:16pm UTC](https://meta.discourse.org/t/postgresql-update-fails-from-china/350869/17 "2025-02-06T14:16:02Z")

</div>

Are you able to reach the repository below from your server?

```plaintext
curl -v https://apt.postgresql.org/pub/repos/apt/

```

The repository is needed to [install](https://github.com/discourse/discourse_docker/blob/efd6bc8ccbd9057c04d909ff48ecf8b704cae3ff/templates/postgres.template.yml#L117-L118) the old PostgreSQL packages used during the update.

> [@sober](#):
>
> I’d rather know what the root cause is that /shared/postgres\_run/.s.PGSQL.5432 cannot connect

This is typically caused when the database was not shut down properly. We had fixed it earlier when you started and stopped the `data` container. The error is not seen in your [latest log output](https://meta.discourse.org/t/postgresql-update-fails-from-china/350869/11).

---

_[View the full topic](https://meta.discourse.org/t/postgresql-update-fails-from-china/350869)._
