# PostgreSQL update fails from China

**URL:** https://meta.discourse.org/t/postgresql-update-fails-from-china/350869
**Category:** Support
**Created:** [February 6, 2025, 10:58am UTC](https://meta.discourse.org/t/postgresql-update-fails-from-china/350869 "2025-02-06T10:58:57Z")
**Posts on this page:** 1
**Showing post:** 2

<div class="post-metadata">

### Author: ![mwaniki](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/mwaniki/32/313097_2.png) [@mwaniki](https://meta.discourse.org/u/mwaniki)
#### Post date: [February 6, 2025, 5:31am UTC](https://meta.discourse.org/t/postgresql-update-fails-from-china/350869/2 "2025-02-06T05:31:29Z")

</div>

Your logs appear to be incomplete but the snippet below can provide a hint.

> socat[33] E connect(, AF=1 “/shared/postgres\_run/.s.PGSQL.5432”, 36): Connection refused

Are you also seeing the error below much lower in your log output?

> The source cluster was not shut down cleanly

If so, you can try following [these instructions](https://meta.discourse.org/t/postgresql-15-update/349515#p-1698209-the-source-cluster-was-not-shut-down-cleanly-10).

---

_[View the full topic](https://meta.discourse.org/t/postgresql-update-fails-from-china/350869)._
