Posts from a particular category missing from homepage - just for the admin user


#1

Hi,

Posts from a particular category missing from homepage
This is the only category in which I have enabled the “solved” plugin.

Just before this happened, this is what I was doing:
I accessed the category URL, appended ?solved=no to it and was browsing through the posts.
And I was marking solutions. (as admin user).
Once I was done with it, I went back to the homepage.
And found it was no more showing any posts from that category.
I tried everything , like refresh etc.
Posts from that category is missing just for the admin user.


Editing category settings causes category to be muted for the current user
(Joshua Rosenfeld) #2

Best guess is while enabling solved for the category you accidentally checked “suppress from homepage” as well.


#3

But I’ve been using this plugin for more than a month now.
Things were normal 30 minutes ago.
( I even tried disabling the plugin - that didn’t help either)

EDIT:
“Suppress from homepage” is unchecked.

EDIT:
I can see some posts from that category are actually there in the homepage. When I say some I mean 2% of the posts from that category. Some of them are solved and some are unsolved.

EDIT:
This is happening with just the admin user. (in pc as well as mobile)
When I logged out from that account - everything shows up well.
For other users and “users with no accounts” - everything is showing up well.

So I’m really not able to isolate the issue here.

My conclusions:
What I did “in those 10-15 minutes” has caused this.
It has affected just my admin account. (in both pc and mobile)

What I “did in those 10-15min” that broke things:
Access the category URL in which I have enabled the “solved” plugin and then appended “solved=no” to the URL and was browsing the topics and marking solutions there. I scrolled down like 7-8 pages and would have accessed like 70-80 topics in this 10-15 minutes. Once this was done, I went back to the homepage and saw things were broken there as I mentioned above.

UPDATE:
I removed the “solved” plugin completely. That didn’t fix things either.
So, I’m guessing something else is wrong.
Like @david pointed above in his below post, I’m also guessing it has something to do with the bug that he talked about in his thread.


(David Taylor) #4

Sounds like it could be another occurance of this bug:

But normally refreshing would fix that.

Have you accidentally muted a load of topics on your account? Try going to /latest?state=muted


(David Taylor) #5

Did you try checking your muted topics?


#6

@david
How to check for muted topics?


(David Taylor) #7

Like this:


#8

I checked that, nothing is showing as muted.


(David Taylor) #9

Maybe the category is muted?

Go to your user preferences, the categories tab, then see if anything is listed under “muted”?
Also check the same thing under the “tags” tab, if you have tags enabled on your forum.


#10

It was indeed muted. Yes, the category was muted. You saved my life. How can I thank you. And things are looking good now.

But I really wonder how this is even possible?
Reason:

  1. I am the only one who access this account.
  2. I did not go to preferences and mute it myself (I’m 100% sure)
  3. Everything was working perfectly before “I did what I mentioned above”. And in those 15-20 minutes I’m sure I didn’t manually mute it myself. It got muted on its own.
  4. Also, some posts from that category was still showing up. (like 2% of the posts). When the category is “muted” it shouldn’t show up any posts from that category - right?

NOTE:
I’m glad things are back to normal for me now. But there are those questions for which I’m not finding an answer to. And I’m willing to cooperate with anyone interested in fixing this bug. I can supply my admin credentials too for this.


(Jeff Atwood) #11

Just so you know, you aren’t crazy, this was our bug:

Thanks for the detective work @david and @joffreyjaffeux will check in later to make sure all is well.


(Joffrey Jaffeux) #12

I just deployed a fix on discourse/master branch and here on meta, it appears to be working correctly.


(Jeff Atwood) #13

You may want to query for users who have “accidentally” muted categories in that time frame?