Prevent login popup


(Sybren) #1

Hey all,

In short: how do we prevent the “Log In” button from creating a popup window?

We disabled local accounts on our Discourse instance, and only allow login with our own OAuth2 server. Right now when I click on “Log In”, a popup is created to show the OAuth2 login of our server. This popup is unnecessary, as the OAuth2 process works fine when running in the same window. Furthermore, the popup is too small and has its scrollbar removed. In my humble opinion, those are three things that shouldn’t happen:

  1. Create an unnecessary popup.
  2. Make it too small.
  3. Don’t allow people to scroll.

These problems are also evident on this site (talking about meta.discourse.org here). For example, when you choose to log in with a Github account, the popup is so small that the “Sign In” button is not visible and even the scrollbar has been actively removed from it.

The “Log in” button at Mozilla’s Discourse does not show a popup, and behaves the way I’d like our own install to behave. How do I do that? Is this a setting I overlooked? Is this done via a plugin?

Cheers,
Sybren