Preview-digest error


(Hosein Naseri) #1

I have just installed discourse and am testing it. in email section, when i click on preview-digest tab, it says:

server fault when trying to load admin/email/preview-digest.json
500 Internal Server Error

what is wrong?


(Sam Saffron) #2

@neil worth a look

Is there anything in /logs ?


(Hosein Naseri) #3

I think it produces the following error:

ArgumentError (comparison of String with ActiveSupport::TimeWithZone failed) /var/www/discourse/app/controllers/list_controller.rb:354:in>’`


(Neil Lalonde) #4

Hmm that doesn’t look related because it doesn’t use the list_controller… It should be the admin/email_controller.rb. Are there any errors for that?


(Hosein Naseri) #5

No I don’t see any error reported for email_controller.rb


(Neil Lalonde) #6

Ok, I don’t know how to reproduce it… Based on your first post, I tried a fresh install, went to Admin > Email > Preview Digest, and it worked. Anything else different about your test install?


(Hosein Naseri) #7

I’ve installed discourse alongside VestaCP if that makes any difference. And also the language of my discourse is Persian.
Does it require anything? maybe I didn’t configure something.


(Neil Lalonde) #8

I guess I’ll have to watch for it somewhere I can reproduce it and see an error.


(Hosein Naseri) #9

Is it a serious problem? I mean Can I ignore it for now? I want to lunch my forum.


(Hosein Naseri) #10

I can confirm that its a language issue. when I change the language to English, its ok. However when I change it to Persian (فارسی) it gives the same error.


(Jeff Atwood) #11

Then it’s a translation error, not a bug…


(Neil Lalonde) #12

Aha, I did find a problem in that case and made a fix. There are probably other languages affected.


(Hosein Naseri) #13

thanks. How should I update it?


(Neil Lalonde) #14

We’re planning to release a new version today, so the fix will be included in that update.


(Pad Pors) #15

sorry to bring this up! currently the preview digest is shown without error, but when I want to send a test email I got 500 Internal Server Error.

the forum is Persian (rtl).

the error log which may be related to this:

ArgumentError (comparison of String with ActiveSupport::TimeWithZone failed) /var/www/discourse/app/controllers/list_controller.rb:395:in `>'


(Hosein Naseri) #16

check this out: