Problem is installing plugin

I follow this topic for installing plugin

After that, what I put around 7 plugin in a row.

This is error came during rebuilding

What wrong I did

May be any plugin installation is causing problem.

What plugin I choose to install

These are the plugin I tried to install at a single time.

Also, My website is goes down now.:expressionless::expressionless::expressionless::expressionless:

When you scrolled up and looked at the earlier error messages what did you see?

Was there a line with a plugin name in it?

1 Like

May be this one

There will be an error message mentioning which plugin is causing the problem farther up in the rebuild.

Failing that, edit your app.yml and put a “#” at the beginning of each new plugin, then do a rebuild to see that the rebuild will actually complete, then step through each new plugin removing the “#” before each plugin and rebuilding again.

It’s a bit more bother to run a rebuild for each and every plugin, but this way you can trap which one(s) are causing the rebuild to fail.

Also, check here on meta to see if others are having trouble with each plugin before you add it to your site.

Layouts it is then.

Remove/comment that line out of app.yml and rebuild.


Just going to try this.

It looks like it is a problem with this plugin written by @angus

For now, you could comment out or remove that line from your yml file.

1 Like

Just remove, now rebuilding

Problem solved. Thanks everyone here

1 Like

I think the layouts-custom-html plugin is not a “stand-alone” but requires the discourse-layouts plugin as that is where DiscourseLayouts is


Yup, the layouts-custom-html widget requires the Custom Layouts plugin.

Sorry, it’s probably a bit confusing if you’re coming to this cold.

I’ve added a note in the readme and wrapped the layouts widgets in event hooks tied to the layouts plugin, so they won’t try to access the CustomLayouts class if it hasn’t loaded (e.g. if you haven’t included the Custom Layouts plugin) and subsequently won’t cause an error in such cases.