Problem running `./launcher rebuild app` : no output and nothing appears to happen


(Chris Croome) #1

I have upgraded one discourse server without a problem, following these steps but on a second one, after a git pull, when I run ./launcher rebuild app nothing happens, there is no terminal output.

I have tried docker stop app and then ./launcher rebuild app and still no output and also ./launcher start app doesn’t appear to start anything and also has no output.

The only difference with the server that upgraded without a problem is that this site has a Nginx reverse proxy with HTTP Authentication, could this be causing a problem? I have read through the launcher script and can’t see why it might.

Does anyone have any suggestions for what I could try next? Thanks.


(Jay Pfaffman) #2

That’s very strange. Maybe reboot.


(Chris Croome) #3

“Maybe reboot”, sorry but that sounds like a solution for a Windows machine… :frowning:

There must be some other things I can try before a last resort like that?

docker info reports that there are 9 running containers.

Does anyone have any other suggestions regarding how to debug this?


(Chris Croome) #4

There is a new version of docker-ce out so I upgraded that and then everything started working as expected, I still don’t know why I was having problems, but all seems to be good now :slight_smile: